更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM汇编置入代码检测文本型数组成员中是否包含0字节空文本字符串 (返回逻辑型)

[复制链接]
查看170 | 回复2 | 2019-7-28 20:21:36 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 A, 文本型, , "0"

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. A = { “1”, “2”, “3”, “4”, “5” }

  10. 输出调试文本 (文本型数组_是否有空文本 (A))
  11. 重定义数组 (A, 假, 0)

  12. 输出调试文本 (文本型数组_是否有空文本 (A))
  13. A = { “1”, “2”, “”, “4”, “5” }

  14. 输出调试文本 (文本型数组_是否有空文本 (A))


  15. .子程序 文本型数组_是否有空文本, 逻辑型, 公开, 文本型数组包含0字节空文本返回真,否则返回假,0成员数组也返回假。
  16. .参数 数组, 文本型, 数组

  17. 置入代码 ({ 83, 81, 82, 139, 69, 8, 139, 0, 139, 88, 4, 131, 192, 8, 51, 201, 235, 22, 139, 20, 136, 11, 210, 117, 4, 51, 192, 235, 20, 138, 18, 10, 210, 117, 4, 51, 192, 235, 10, 65, 59, 203, 114, 230, 184, 1, 0, 0, 0, 131, 240, 1, 90, 89, 91, 201, 194, 4, 0 })
  18. ' push ebx
  19. ' push ecx
  20. ' push edx
  21. ' mov eax,[ebp+8]
  22. ' mov eax,[eax]
  23. ' mov ebx,[eax+4]
  24. ' add eax,8
  25. ' xor ecx,ecx
  26. ' .while ecx<ebx
  27. ' mov edx,[eax+ecx*4]
  28. ' .if edx == 0
  29. ' xor eax,eax
  30. ' jmp ASM_END
  31. ' .endif
  32. ' mov dl,[edx]
  33. ' .if dl == 0
  34. ' xor eax,eax
  35. ' jmp ASM_END
  36. ' .endif
  37. ' inc ecx
  38. ' .endw
  39. ' mov eax,1
  40. ' ASM_END:
  41. ' xor eax,1
  42. ' pop edx
  43. ' pop ecx
  44. ' pop ebx
  45. ' leave
  46. ' retn 4

  47. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则