免费邀请码更改用户名领国庆勋章CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 90|回复: 2
收起左侧

易语言MASM置入代码实现文本型数组所有成员清除为0字节空文本(不影响成员数,无返回值)

[复制链接]
发表于 2019-7-30 07:38:49 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 QAQ 于 2019-7-30 07:38 编辑

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 数组, 文本型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 数组 = { “Hello World!”, “中文测试”, “1234567890” }
  11. 调试输出 (数组)
  12. 文本型数组_清除 (数组)
  13. 调试输出 (数组)


  14. .子程序 文本型数组_清除, , 公开
  15. .参数 数组, 文本型, 数组

  16. 置入代码 ({ 96, 139, 69, 8, 139, 0, 139, 88, 4, 131, 192, 8, 51, 201, 178, 0, 235, 10, 139, 52, 136, 11, 246, 116, 2, 136, 22, 65, 59, 203, 114, 242, 97, 201, 194, 4, 0 })
  17. ' pushad
  18. ' mov eax,[ebp+8]
  19. ' mov eax,[eax]
  20. ' mov ebx,[eax+4]
  21. ' add eax,8
  22. ' xor ecx,ecx
  23. ' mov dl,0
  24. ' .while ecx < ebx
  25. ' mov esi,[eax+ecx*4]
  26. ' .if esi != 0
  27. ' mov [esi],dl
  28. ' .endif
  29. ' inc ecx
  30. ' .endw
  31. ' popad
  32. ' leave
  33. ' retn 4

复制代码

相关帖子

回复

使用道具 举报

腾讯云服务器安全可靠高性能,多种配置供您选择
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则