免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 100|回复: 1
收起左侧

易语言汇编MASM置入代码实现清除文本型数组中所有的0字节空成员字符串 (无返回值)

[复制链接]
发表于 2019-8-1 10:01:39 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 文本型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A = { “123”, “456”, “”, “”, “789”, “AA”, “”, “BB”, “ ” }
  11. 调试输出 (A)
  12. 文本型数组_清除空文本 (A)
  13. 调试输出 (A)

  14. .子程序 文本型数组_清除空文本, , 公开, 清除文本型数组中所有的空文本成员
  15. .参数 文本型数组, 文本型, 参考 数组, 必须为数组变量
  16. .局部变量 空文本位置, 整数型

  17. .判断循环首 (真)
  18.     置入代码 ({ 235, 23, 80, 11, 192, 117, 4, 177, 1, 235, 12, 138, 0, 10, 192, 117, 4, 177, 1, 235, 2, 50, 201, 88, 195, 96, 139, 85, 8, 139, 18, 139, 90, 4, 131, 194, 8, 51, 246, 235, 20, 139, 4, 178, 232, 209, 255, 255, 255, 128, 249, 1, 117, 6, 70, 137, 117, 252, 235, 13, 70, 59, 243, 114, 232, 184, 0, 0, 0, 0, 137, 69, 252, 97 })
  19.     ' jmp START
  20.     ' IS_TEXT_NULL2:
  21.     ' push eax
  22.     ' .if eax == 0
  23.     ' mov cl,1
  24.     ' jmp IS_TEXT_NULL2_END
  25.     ' .endif
  26.     ' mov al,[eax]
  27.     ' .if al == 0
  28.     ' mov cl,1
  29.     ' jmp IS_TEXT_NULL2_END
  30.     ' .endif
  31.     ' xor cl,cl
  32.     ' IS_TEXT_NULL2_END:
  33.     ' pop eax
  34.     ' ret
  35.     ' START:
  36.     ' pushad
  37.     ' mov edx,[ebp+8]
  38.     ' mov edx,[edx]
  39.     ' mov ebx,[edx+4]
  40.     ' add edx,8
  41.     ' xor esi,esi
  42.     ' .while esi < ebx
  43.     ' mov eax,[edx+esi*4]
  44.     ' call IS_TEXT_NULL2
  45.     ' .if cl == 1
  46.     ' inc esi
  47.     ' mov [ebp-4],esi
  48.     ' jmp ASM_END
  49.     ' .endif
  50.     ' inc esi
  51.     ' .endw
  52.     ' mov eax,0
  53.     ' mov [ebp-4],eax
  54.     ' ASM_END:
  55.     ' popad

  56.     .如果 (空文本位置 = 0)
  57.         返回 ()
  58.     .否则
  59.         删除成员 (文本型数组, 空文本位置, 1)
  60.     .如果结束

  61. .判断循环尾 ()
复制代码

相关帖子

回复

使用道具 举报

腾讯云新春采购节 热门云产品3折起,爆款超值秒杀,新购高额满返,升级享优惠大礼包!
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 00:42, 100.26.182.28 , Processed in 0.582201 second(s), 30 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表