更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 203|回复: 2
收起左侧

易语言MASM置入代码从指定内存地址获取数据并写入字节集 指针写字节集() (无返回值)

[复制链接]
发表于 2019-8-5 06:02:31 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 字节集, 字节集
  9. .局部变量 文本, 文本型
  10. .局部变量 指针, 整数型

  11. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  12. 字节集 = 取空白字节集 (10)
  13. 文本 = “0123456789”
  14. 指针 = 取变量数据地址 (文本)
  15. 调试输出 (指针)
  16. 指针写字节集 (指针, 字节集)
  17. 调试输出 (字节集)

  18. .子程序 指针写字节集, , 公开, 将指定指针的数据写入字节集
  19. .参数 内存数据指针, 整数型, , 从该指针获取数据,写入长度为字节集长度
  20. .参数 字节集数据, 字节集, 参考, 必须为字节集变量,操作前应该 取空白字节集()

  21. 置入代码 ({ 96, 139, 69, 8, 139, 117, 12, 139, 54, 139, 86, 4, 131, 198, 8, 51, 219, 235, 7, 138, 12, 3, 136, 12, 51, 67, 59, 218, 114, 245, 97 })
  22. ' pushad
  23. ' mov eax,[ebp+8]
  24. ' mov esi,[ebp+12]
  25. ' mov esi,[esi]
  26. ' mov edx,[esi+4]
  27. ' add esi,8
  28. ' xor ebx,ebx
  29. ' .while ebx < edx
  30. ' mov cl,[eax+ebx]
  31. ' mov [esi+ebx],cl
  32. ' inc ebx
  33. ' .endw
  34. ' popad

复制代码

相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则