免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 43|回复: 1
收起左侧

易语言MASM置入代码实现指针与整数比较,指针到整数检测是否等于其他整数 (返回逻辑型)

[复制链接]
发表于 2019-8-7 18:00:39 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 整数型

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A = 1234567890

  11. 输出调试文本 (指针比较整数 (取变量数据地址 (A), 1234567890))

  12. 输出调试文本 (指针比较整数 (取变量数据地址 (A) + 1, 1234567890))

  13. 输出调试文本 (指针比较整数_易源码 (取变量数据地址 (A), 1234567890))

  14. 输出调试文本 (指针比较整数_易源码 (取变量数据地址 (A) + 1, 1234567890))
  15. A = 0

  16. 输出调试文本 (指针比较整数 (取变量数据地址 (A), 1234567890))

  17. 输出调试文本 (指针比较整数 (取变量数据地址 (A) + 1, 1234567890))

  18. 输出调试文本 (指针比较整数_易源码 (取变量数据地址 (A), 1234567890))

  19. 输出调试文本 (指针比较整数_易源码 (取变量数据地址 (A) + 1, 1234567890))


  20. .子程序 指针比较整数, 逻辑型, 公开
  21. .参数 指针, 整数型
  22. .参数 整数, 整数型

  23. 置入代码 ({ 139, 69, 8, 139, 0, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  24. ' mov eax,[ebp+8]
  25. ' mov eax,[eax]
  26. ' .if eax == [ebp+12]
  27. ' mov eax,1
  28. ' .elseif
  29. ' xor eax,eax
  30. ' .endif
  31. ' leave
  32. ' retn 8
  33. 返回 (假)

  34. .子程序 指针比较整数_易源码, 逻辑型
  35. .参数 指针, 整数型
  36. .参数 整数, 整数型

  37. 返回 (指针到整数 (指针) = 整数)

复制代码

回复

使用道具 举报

腾讯云新春采购节 热门云产品3折起,爆款超值秒杀,新购高额满返,升级享优惠大礼包!
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-8-25 15:06, 34.236.190.216 , Processed in 0.062500 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表