免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 31|回复: 0
收起左侧

易语言MASM置入代码内存指针地址,长度填充随机字节值 内存区域随机数覆盖 (无返回值)

[复制链接]
发表于 2019-8-9 09:18:10 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  5. 置随机数种子 ()
  6. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  7. 返回 (0)  ' 可以根据您的需要返回任意数值

  8. .子程序 _临时子程序
  9. .局部变量 指针, 整数型

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  11. 指针 = 申请内存 (256, 真)
  12. 调试输出 (指针到字节集 (指针, 256))
  13. 内存填充_随机 (指针, 256)
  14. 调试输出 (指针到字节集 (指针, 256))
  15. 内存填充_随机 (指针, 256)
  16. 调试输出 (指针到字节集 (指针, 256))



  17. .子程序 内存填充_随机, , 公开
  18. .参数 内存数据指针, 整数型
  19. .参数 内存数据长度, 整数型
  20. .局部变量 随机字节指针, 子程序指针

  21. 随机字节指针 = &取随机字节
  22. 置入代码 ({ 96, 139, 125, 8, 139, 93, 12, 139, 77, 252, 51, 246, 235, 8, 81, 255, 209, 89, 136, 4, 62, 70, 59, 243, 114, 244, 97 })
  23. ' pusha
  24. ' mov edi,[ebp+8]
  25. ' mov ebx,[ebp+12]
  26. ' mov ecx,[ebp-4]
  27. ' xor esi,esi
  28. ' .while esi < ebx
  29. ' push ecx
  30. ' call ecx
  31. ' pop ecx
  32. ' mov [edi+esi],al
  33. ' inc esi
  34. ' .endw
  35. ' popa


  36. .子程序 取随机字节, 字节型

  37. 返回 (取随机数 (0, 255))
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-8-25 14:32, 34.236.190.216 , Processed in 0.110351 second(s), 28 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表