免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 25|回复: 0
收起左侧

易语言MASM汇编置入代码实现字节集数据/字节型数组填充覆盖随机字节型数值 (无返回值)

[复制链接]
发表于 2019-8-10 16:06:02 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  5. 置随机数种子 ()
  6. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  7. 返回 (0)  ' 可以根据您的需要返回任意数值

  8. .子程序 _临时子程序
  9. .局部变量 A, 字节集
  10. .局部变量 B, 字节型, , "256"

  11. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  12. A = 取空白字节集 (256)
  13. 字节集_填充随机 (A)
  14. 字节型数组_填充随机 (B)
  15. 调试输出 (A)
  16. 调试输出 (B)

  17. .子程序 字节集_填充随机, , 公开
  18. .参数 字节集, 字节集, 参考, 必须为字节集变量
  19. .局部变量 随机字节指针, 子程序指针

  20. 随机字节指针 = &取随机字节
  21. 置入代码 ({ 96, 139, 117, 8, 139, 54, 139, 126, 4, 131, 198, 8, 139, 93, 252, 51, 210, 235, 8, 82, 255, 211, 90, 136, 4, 50, 66, 59, 215, 114, 244, 97 })
  22. ' pusha
  23. ' mov esi,[ebp+8]
  24. ' mov esi,[esi]
  25. ' mov edi,[esi+4]
  26. ' add esi,8
  27. ' mov ebx,[ebp-4]
  28. ' xor edx,edx
  29. ' .while edx < edi
  30. ' push edx
  31. ' call ebx
  32. ' pop edx
  33. ' mov [esi+edx],al
  34. ' inc edx
  35. ' .endw
  36. ' popa



  37. .子程序 字节型数组_填充随机, , 公开
  38. .参数 字节型数组, 字节型, 参考 数组, 必须为数组变量
  39. .局部变量 随机字节指针, 子程序指针

  40. 随机字节指针 = &取随机字节
  41. 置入代码 ({ 96, 139, 117, 8, 139, 54, 139, 126, 4, 131, 198, 8, 139, 93, 252, 51, 210, 235, 8, 82, 255, 211, 90, 136, 4, 50, 66, 59, 215, 114, 244, 97 })
  42. ' pusha
  43. ' mov esi,[ebp+8]
  44. ' mov esi,[esi]
  45. ' mov edi,[esi+4]
  46. ' add esi,8
  47. ' mov ebx,[ebp-4]
  48. ' xor edx,edx
  49. ' .while edx < edi
  50. ' push edx
  51. ' call ebx
  52. ' pop edx
  53. ' mov [esi+edx],al
  54. ' inc edx
  55. ' .endw
  56. ' popa



  57. .子程序 取随机字节, 字节型

  58. 返回 (取随机数 (0, 255))

复制代码
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-8-25 15:43, 34.236.190.216 , Processed in 0.158203 second(s), 28 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表