更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 117|回复: 1
收起左侧

易语言MASM汇编置入代码实现子程序指针数组与整数型数组极速互转模块源码 (无返回值)

[复制链接]
发表于 2019-8-11 08:45:23 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 整数型, , "0"
  9. .局部变量 B, 子程序指针, , "0"

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. A = { 1, 2, 3, 4, 5, -1, -2, -3, -4, -5 }
  12. 整数型数组到子程序指针数组 (A, B)
  13. 调试输出 (A, B)
  14. B = { &子程序1, &子程序2, &子程序3 }
  15. 子程序指针数组到整数型数组 (B, A)
  16. 调试输出 (A, B)


  17. .子程序 子程序指针数组到整数型数组, , 公开
  18. .参数 子程序指针数组, 子程序指针, 数组
  19. .参数 整数型数组, 整数型, 参考 数组, 必须为数组变量

  20. 重定义数组 (整数型数组, 真, 取数组成员数 (子程序指针数组))
  21. 置入代码 ({ 96, 139, 117, 8, 139, 54, 139, 93, 12, 139, 27, 131, 195, 8, 139, 126, 4, 131, 198, 8, 51, 201, 235, 7, 139, 4, 142, 137, 4, 139, 65, 59, 207, 114, 245, 97 })
  22. ' pusha
  23. ' mov esi,[ebp+8]
  24. ' mov esi,[esi]
  25. ' mov ebx,[ebp+12]
  26. ' mov ebx,[ebx]
  27. ' add ebx,8
  28. ' mov edi,[esi+4]
  29. ' add esi,8
  30. ' xor ecx,ecx
  31. ' .while ecx < edi
  32. ' mov eax,[esi+ecx*4]
  33. ' mov [ebx+ecx*4],eax
  34. ' inc ecx
  35. ' .endw
  36. ' popa


  37. .子程序 整数型数组到子程序指针数组, , 公开
  38. .参数 整数型数组, 整数型, 数组
  39. .参数 子程序指针数组, 子程序指针, 参考 数组, 必须为数组变量

  40. 重定义数组 (子程序指针数组, 真, 取数组成员数 (整数型数组))
  41. 置入代码 ({ 96, 139, 117, 8, 139, 54, 139, 93, 12, 139, 27, 131, 195, 8, 139, 126, 4, 131, 198, 8, 51, 201, 235, 7, 139, 4, 142, 137, 4, 139, 65, 59, 207, 114, 245, 97 })
  42. ' pusha
  43. ' mov esi,[ebp+8]
  44. ' mov esi,[esi]
  45. ' mov ebx,[ebp+12]
  46. ' mov ebx,[ebx]
  47. ' add ebx,8
  48. ' mov edi,[esi+4]
  49. ' add esi,8
  50. ' xor ecx,ecx
  51. ' .while ecx < edi
  52. ' mov eax,[esi+ecx*4]
  53. ' mov [ebx+ecx*4],eax
  54. ' inc ecx
  55. ' .endw
  56. ' popa



  57. .子程序 子程序1



  58. .子程序 子程序2



  59. .子程序 子程序3


复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则