免扫码快速登录设为首页收藏本站帮助中心
查看: 183|回复: 2
收起左侧

易语言MASM汇编置入代码文本型变量填充覆盖随机Ascii字符(不含0)乱码文本 (无返回值)

[复制链接]
发表于 2019-8-12 09:02:16 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  5. 置随机数种子 ()
  6. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  7. 返回 (0)  ' 可以根据您的需要返回任意数值

  8. .子程序 _临时子程序
  9. .局部变量 文本, 文本型

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. 文本 = 取空白文本 (256)
  12. 文本型_填充乱码 (文本)
  13. 调试输出 (文本, 取文本长度 (文本))
  14. 文本型_填充乱码 (文本)
  15. 调试输出 (文本, 取文本长度 (文本))
  16. 文本型_填充乱码 (文本)
  17. 调试输出 (文本, 取文本长度 (文本))
  18. 文本型_填充乱码 (文本)
  19. 调试输出 (文本, 取文本长度 (文本))



  20. .子程序 文本型_填充乱码
  21. .参数 文本型, 文本型, 参考
  22. .局部变量 随机字节指针, 子程序指针

  23. 随机字节指针 = &取随机字节_无零
  24. 置入代码 ({ 96, 139, 69, 8, 139, 0, 232, 5, 0, 0, 0, 97, 201, 194, 4, 0, 96, 139, 77, 252, 139, 216, 138, 3, 10, 192, 117, 2, 97, 195, 81, 255, 209, 89, 136, 3, 67, 235, 239 })
  25. ' pusha
  26. ' mov eax,[ebp+8]
  27. ' mov eax,[eax]
  28. ' call TEXT_RAND
  29. ' popa
  30. ' leave
  31. ' retn 4
  32. ' TEXT_RAND:
  33. ' pusha
  34. ' mov ecx,[ebp-4]
  35. ' mov ebx,eax
  36. ' TEXT_RAND_LOOP:
  37. ' mov al,[ebx]
  38. ' .if al == 0
  39. ' popa
  40. ' ret
  41. ' .endif
  42. ' push ecx
  43. ' call ecx
  44. ' pop ecx
  45. ' mov [ebx],al
  46. ' inc ebx
  47. ' jmp TEXT_RAND_LOOP


  48. .子程序 取随机字节_无零, 字节型

  49. 返回 (取随机数 (1, 255))
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则