更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM汇编置入代码简易循环随机延时延迟 同样数值时间越短CPU主频越高(无返回值)

[复制链接]
查看110 | 回复1 | 2019-8-15 20:00:10 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 时间, 整数型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 时间 = 取启动时间 ()

  10. 随机延时 (-1)
  11. 输出调试文本 (取启动时间 () - 时间)


  12. .子程序 随机延时, , 公开, 同样的数值,时间越短CPU主频越高,请勿按微秒毫秒精确延时
  13. .参数 延时数值, 整数型, , 按无符号整数型延时

  14. 置入代码 ({ 80, 83, 139, 93, 8, 51, 192, 235, 1, 64, 59, 195, 114, 251, 91, 88 })
  15. ' push eax
  16. ' push ebx
  17. ' mov ebx,[ebp+8]
  18. ' xor eax,eax
  19. ' .while eax < ebx
  20. ' inc eax
  21. ' .endw
  22. ' pop ebx
  23. ' pop eax

复制代码


相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则