免扫码快速登录设为首页收藏本站帮助中心
查看: 150|回复: 1
收起左侧

易语言MASM汇编置入代码实现文本型与字节集互转 文本型到字节集()、字节集到文本型()

[复制链接]
发表于 2019-8-26 08:03:18 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (文本型到字节集 (“0123456789”))
  10. 调试输出 (字节集到文本型 ({ 72, 101, 108, 108, 111, 32, 87, 111, 114, 108, 100, 33, 214, 208, 206, 196, 178, 226, 202, 212 }))


  11. .子程序 文本型到字节集, 字节集, 公开
  12. .参数 文本型, 文本型
  13. .局部变量 返回值, 字节集

  14. 返回值 = 取空白字节集 (取文本长度 (文本型))
  15. 置入代码 ({ 96, 139, 117, 252, 11, 246, 117, 2, 235, 34, 139, 126, 4, 11, 255, 117, 2, 235, 25, 131, 198, 8, 139, 69, 8, 139, 0, 51, 255, 138, 24, 10, 219, 117, 2, 235, 7, 136, 28, 55, 71, 64, 235, 241, 97 })
  16. ' pushad
  17. ' mov esi,[ebp-4]
  18. ' .if esi == 0
  19. ' jmp ASM_END
  20. ' .endif
  21. ' mov edi,[esi+4]
  22. ' .if edi == 0
  23. ' jmp ASM_END
  24. ' .endif
  25. ' add esi,8
  26. ' mov eax,[ebp+8]
  27. ' mov eax,[eax]
  28. ' xor edi,edi
  29. ' .while 1
  30. ' mov bl,[eax]
  31. ' .if !bl
  32. ' .break
  33. ' .endif
  34. ' mov [esi+edi],bl
  35. ' inc edi
  36. ' inc eax
  37. ' .endw
  38. ' ASM_END:
  39. ' popad
  40. 返回 (返回值)



  41. .子程序 字节集到文本型, 文本型, 公开
  42. .参数 字节集, 字节集
  43. .局部变量 返回值, 文本型

  44. 返回值 = 取空白文本 (取字节集长度 (字节集))
  45. 置入代码 ({ 96, 139, 117, 8, 11, 246, 117, 2, 235, 40, 139, 54, 11, 246, 117, 2, 235, 32, 139, 126, 4, 11, 255, 117, 2, 235, 23, 131, 198, 8, 139, 69, 252, 51, 255, 138, 28, 55, 136, 24, 10, 219, 117, 2, 235, 4, 71, 64, 235, 241, 97 })
  46. ' pushad
  47. ' mov esi,[ebp+8]
  48. ' .if esi == 0
  49. ' jmp ASM_END
  50. ' .endif
  51. ' mov esi,[esi]
  52. ' .if esi == 0
  53. ' jmp ASM_END
  54. ' .endif
  55. ' mov edi,[esi+4]
  56. ' .if edi == 0
  57. ' jmp ASM_END
  58. ' .endif
  59. ' add esi,8
  60. ' mov eax,[ebp-4]
  61. ' xor edi,edi
  62. ' .while 1
  63. ' mov bl,[esi+edi]
  64. ' mov [eax],bl
  65. ' .if bl == 0
  66. ' .break
  67. ' .endif
  68. ' inc edi
  69. ' inc eax
  70. ' .endw
  71. ' ASM_END:
  72. ' popad

  73. 返回 (返回值)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则