免扫码快速登录设为首页收藏本站帮助中心
查看: 191|回复: 1
收起左侧

易语言MASM置入代码文本型字符串的URL编码解码 PHP的urldecode()函数算法(返回字节集)

[复制链接]
发表于 2019-9-1 16:01:26 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 解码后, 字节集

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. 解码后 = URL解码 (“Hello+World%21%d6%D0%CE%C4%B2%E2%CA%D41234567890%2b%2B”)
  11. 调试输出 (解码后, 到文本 (解码后))


  12. .子程序 URL解码, 字节集, 公开, 与PHP的 urldecode() 函数功能相同
  13. .参数 文本, 文本型
  14. .局部变量 返回值, 字节集

  15. 返回值 = 取空白字节集 (取文本长度 (文本))
  16. 置入代码 ({ 235, 113, 128, 249, 48, 114, 7, 128, 249, 57, 119, 2, 235, 26, 128, 249, 65, 114, 7, 128, 249, 70, 119, 2, 235, 14, 128, 249, 97, 114, 7, 128, 249, 102, 119, 2, 235, 2, 50, 201, 195, 128, 250, 48, 114, 10, 128, 250, 57, 119, 5, 128, 234, 48, 235, 32, 128, 250, 65, 114, 10, 128, 250, 70, 119, 5, 128, 234, 55, 235, 17, 128, 250, 97, 114, 10, 128, 250, 102, 119, 5, 128, 234, 87, 235, 2, 50, 210, 195, 102, 82, 138, 213, 232, 199, 255, 255, 255, 138, 218, 192, 227, 4, 138, 209, 232, 187, 255, 255, 255, 10, 218, 102, 90, 195, 80, 83, 81, 82, 86, 87, 139, 117, 252, 11, 246, 117, 2, 235, 110, 139, 126, 4, 11, 255, 117, 2, 235, 101, 131, 198, 8, 139, 69, 8, 11, 192, 117, 2, 235, 89, 139, 0, 11, 192, 117, 2, 235, 81, 51, 255, 50, 255, 138, 24, 10, 219, 117, 2, 235, 66, 128, 251, 37, 117, 33, 138, 72, 1, 232, 74, 255, 255, 255, 10, 201, 116, 21, 138, 233, 138, 72, 2, 232, 60, 255, 255, 255, 10, 201, 116, 7, 183, 1, 232, 136, 255, 255, 255, 128, 251, 43, 117, 6, 10, 255, 117, 2, 179, 32, 136, 28, 55, 71, 128, 255, 1, 117, 5, 131, 192, 3, 235, 1, 64, 235, 180, 137, 126, 252, 95, 94, 90, 89, 91, 88 })
  17. ' jmp MAIN
  18. ' IS_HEX_BYTE:
  19. ' .if cl >= 48 && cl <= 57
  20. ' .elseif cl >= 65 && cl <= 70
  21. ' .elseif cl >= 97 && cl <= 102
  22. ' .else
  23. ' xor cl,cl
  24. ' .endif
  25. ' ret
  26. ' HEX2DEC:
  27. ' .if dl >= 48 && dl <= 57
  28. ' sub dl,48
  29. ' .elseif dl >= 65 && dl <=70
  30. ' sub dl,55
  31. ' .elseif dl >= 97 && dl <=102
  32. ' sub dl,87
  33. ' .else
  34. ' xor dl,dl
  35. ' .endif
  36. ' ret
  37. ' BYTE_HEX2DEC:
  38. ' push dx
  39. ' mov dl,ch
  40. ' call HEX2DEC
  41. ' mov bl,dl
  42. ' shl bl,4
  43. ' mov dl,cl
  44. ' call HEX2DEC
  45. ' or bl,dl
  46. ' pop dx
  47. ' ret
  48. ' MAIN:
  49. ' push eax
  50. ' push ebx
  51. ' push ecx
  52. ' push edx
  53. ' push esi
  54. ' push edi
  55. ' mov esi,[ebp-4]
  56. ' .if esi == 0
  57. ' jmp ASM_END
  58. ' .endif
  59. ' mov edi,[esi+4]
  60. ' .if edi == 0
  61. ' jmp ASM_END
  62. ' .endif
  63. ' add esi,8
  64. ' mov eax,[ebp+8]
  65. ' .if eax == 0
  66. ' jmp ASM_END
  67. ' .endif
  68. ' mov eax,[eax]
  69. ' .if eax == 0
  70. ' jmp ASM_END
  71. ' .endif
  72. ' xor edi,edi
  73. ' .while 1
  74. ' xor bh,bh
  75. ' mov bl,[eax]
  76. ' .if !bl
  77. ' .break
  78. ' .endif
  79. ' .if bl == 37
  80. ' mov cl,[eax+1]
  81. ' call IS_HEX_BYTE
  82. ' .if cl
  83. ' mov ch,cl
  84. ' mov cl,[eax+2]
  85. ' call IS_HEX_BYTE
  86. ' .if cl
  87. ' mov bh,1
  88. ' call BYTE_HEX2DEC
  89. ' .endif
  90. ' .endif
  91. ' .endif
  92. ' .if bl == 43 && bh == 0
  93. ' mov bl,32
  94. ' .endif
  95. ' mov [esi+edi],bl
  96. ' inc edi
  97. ' .if bh == 1
  98. ' add eax,3
  99. ' .elseif
  100. ' inc eax
  101. ' .endif
  102. ' .endw
  103. ' mov [esi-4],edi
  104. ' ASM_END:
  105. ' pop edi
  106. ' pop esi
  107. ' pop edx
  108. ' pop ecx
  109. ' pop ebx
  110. ' pop eax

  111. 返回 (返回值)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则