免扫码快速登录设为首页收藏本站帮助中心
查看: 136|回复: 0
收起左侧

易语言MASM置入代码实现子程序指针与整数型数值的相同/等于/是否一致比较(返回逻辑型)

[复制链接]
发表于 2019-9-4 17:00:46 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 子程序指针
  9. .局部变量 B, 整数型

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. 调试输出 (子程序指针与整数型_等于 (A, B), A, B)
  12. 调试输出 (整数型与子程序指针_等于 (B, A), B, A)
  13. A = &子程序指针与整数型_等于
  14. B = 到整数 (A)

  15. 调试输出 (子程序指针与整数型_等于 (A, B), A, B)
  16. 调试输出 (整数型与子程序指针_等于 (B, A), B, A)
  17. B = 0
  18. 调试输出 (子程序指针与整数型_等于 (A, B), A, B)
  19. 调试输出 (整数型与子程序指针_等于 (B, A), B, A)

  20. .子程序 子程序指针与整数型_等于, 逻辑型, 公开
  21. .参数 子程序指针, 子程序指针
  22. .参数 整数型, 整数型

  23. 置入代码 ({ 139, 69, 8, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  24. ' mov eax,[ebp+8]
  25. ' .if eax == [ebp+12]
  26. ' mov eax,1
  27. ' .else
  28. ' xor eax,eax
  29. ' .endif
  30. ' leave
  31. ' retn 8
  32. 返回 (假)

  33. .子程序 整数型与子程序指针_等于, 逻辑型, 公开
  34. .参数 整数型, 整数型
  35. .参数 子程序指针, 子程序指针

  36. 置入代码 ({ 139, 69, 8, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  37. ' mov eax,[ebp+8]
  38. ' .if eax == [ebp+12]
  39. ' mov eax,1
  40. ' .else
  41. ' xor eax,eax
  42. ' .endif
  43. ' leave
  44. ' retn 8
  45. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则