更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 157|回复: 1
收起左侧

易语言MASM置入代码双精度小数型与长整数型位与/位或/位异或逻辑运算(返回长整数型)

[复制链接]
发表于 2019-9-5 09:00:33 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2

  2. .程序集 程序集1, , , 使用本模块应遵守双精度小数型(IEEE754)编码规则,错误使用将会造成数据异常

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。




  8. .子程序 双精度小数型与长整数型_位与_返回长整数型, 长整数型, 公开
  9. .参数 双精度小数型, 双精度小数型
  10. .参数 长整数型, 长整数型

  11. 置入代码 ({ 139, 69, 8, 139, 85, 12, 35, 69, 16, 35, 85, 20, 201, 194, 8, 0 })
  12. ' mov eax,[ebp+8]
  13. ' mov edx,[ebp+12]
  14. ' and eax,[ebp+16]
  15. ' and edx,[ebp+20]
  16. ' leave
  17. ' retn 8
  18. 返回 (0)

  19. .子程序 双精度小数型与长整数型_位或_返回长整数型, 长整数型, 公开
  20. .参数 双精度小数型, 双精度小数型
  21. .参数 长整数型, 长整数型

  22. 置入代码 ({ 139, 69, 8, 139, 85, 12, 11, 69, 16, 11, 85, 20, 201, 194, 8, 0 })
  23. 'mov eax,[ebp+8]
  24. 'mov edx,[ebp+12]
  25. 'or eax,[ebp+16]
  26. 'or edx,[ebp+20]
  27. 'leave
  28. 'retn 8

  29. 返回 (0)

  30. .子程序 双精度小数型与长整数型_位异或_返回长整数型, 长整数型, 公开
  31. .参数 双精度小数型, 双精度小数型
  32. .参数 长整数型, 长整数型

  33. 置入代码 ({ 139, 69, 8, 139, 85, 12, 51, 69, 16, 51, 85, 20, 201, 194, 8, 0 })
  34. 'mov eax,[ebp+8]
  35. 'mov edx,[ebp+12]
  36. 'xor eax,[ebp+16]
  37. 'xor edx,[ebp+20]
  38. 'leave
  39. 'retn 8

  40. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则