免扫码快速登录设为首页收藏本站帮助中心
查看: 163|回复: 0
收起左侧

易语言MASM置入代码删除/去除文本型字符串开头的半角空格(不支持其他字符,返回逻辑型)

[复制链接]
发表于 2019-9-6 09:04:09 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 文本, 文本型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 文本 = “        Hello World!中文测试    ”
  10. 输出调试文本 (文本)
  11. 输出调试文本 (删首半角空 (文本))
  12. 输出调试文本 (文本)
  13. 输出调试文本 (删首半角空 (文本))

  14. .子程序 删首半角空, 逻辑型, 公开, 有空格删除成功返回真,失败返回假
  15. .参数 文本型, 文本型, 参考, 只可删半角空格、不支持其他字符

  16. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 4, 51, 192, 235, 46, 139, 24, 11, 219, 117, 4, 51, 192, 235, 36, 51, 201, 138, 19, 128, 250, 32, 117, 3, 65, 235, 2, 235, 3, 67, 235, 241, 139, 24, 3, 217, 137, 24, 11, 201, 116, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 90, 89, 91, 201, 194, 4, 0 })
  17. ' push ebx
  18. ' push ecx
  19. ' push edx
  20. ' mov eax,[ebp+8]
  21. ' .if !eax
  22. ' xor eax,eax
  23. ' jmp ASM_END
  24. ' .endif
  25. ' mov ebx,[eax]
  26. ' .if !ebx
  27. ' xor eax,eax
  28. ' jmp ASM_END
  29. ' .endif
  30. ' xor ecx,ecx
  31. ' .while 1
  32. ' mov dl,[ebx]
  33. ' .if dl == 32
  34. ' inc ecx
  35. ' .else
  36. ' .break
  37. ' .endif
  38. ' inc ebx
  39. ' .endw
  40. ' mov ebx,[eax]
  41. ' add ebx,ecx
  42. ' mov [eax],ebx
  43. ' .if ecx
  44. ' mov eax,1
  45. ' .elseif
  46. ' xor eax,eax
  47. ' .endif
  48. ' ASM_END:
  49. ' pop edx
  50. ' pop ecx
  51. ' pop ebx
  52. ' leave
  53. ' retn 4


  54. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则