免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 24|回复: 2
收起左侧

易语言MASM置入代码长整数型相加/相减/加减法运算,解决核心库计算出错 (返回长整数型)

[复制链接]
发表于 2019-9-7 09:06:20 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 长整数型
  9. .局部变量 B, 长整数型

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. A = 到长整数 (“1000000000000000000”)
  12. B = A + 10000
  13. 调试输出 (A, B)
  14. B = 长整数_相加 (A, 10000)
  15. 调试输出 (A, B)

  16. B = A - 10000
  17. 调试输出 (A, B)
  18. B = 长整数_相减 (A, 10000)
  19. 调试输出 (A, B)


  20. .子程序 长整数_相加, 长整数型, 公开
  21. .参数 被加数, 长整数型
  22. .参数 加数, 长整数型

  23. 置入代码 ({ 139, 69, 8, 139, 85, 12, 3, 69, 16, 19, 85, 20, 248, 201, 194, 16, 0 })
  24. ' mov eax,[ebp+8]
  25. ' mov edx,[ebp+12]
  26. ' add eax,[ebp+16]
  27. ' adc edx,[ebp+20]
  28. ' clc
  29. ' leave
  30. ' retn 16


  31. 返回 (0)

  32. .子程序 长整数_相减, 长整数型, 公开
  33. .参数 被减数, 长整数型
  34. .参数 减数, 长整数型

  35. 置入代码 ({ 139, 69, 8, 139, 85, 12, 43, 69, 16, 27, 85, 20, 201, 194, 16, 0 })
  36. ' mov eax,[ebp+8]
  37. ' mov edx,[ebp+12]
  38. ' sub eax,[ebp+16]
  39. ' sbb edx,[ebp+20]
  40. ' leave
  41. ' retn 16

  42. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

腾讯云数据库性能卓越稳定可靠,为您解决数据库运维难题
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 01:31, 100.26.182.28 , Processed in 0.694402 second(s), 38 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表