免扫码快速登录设为首页收藏本站帮助中心
查看: 140|回复: 0
收起左侧

易语言MASM置入代码日期时间型与长整数型位与/位或/位异或逻辑运算模块(返回长整数型)

[复制链接]
发表于 2019-9-13 21:21:21 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1, , , 使用本模块应遵守日期时间型(IEEE754)编码规则,错误使用将会造成数据异常

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  8. 输出调试文本 (日期时间型与长整数型_位与 (取现行时间 (), -1))
  9. 输出调试文本 (日期时间型与长整数型_位或 (取现行时间 (), -1))
  10. 输出调试文本 (日期时间型与长整数型_位异或 (取现行时间 (), 1234567890))




  11. .子程序 日期时间型与长整数型_位与, 长整数型, 公开
  12. .参数 日期时间型, 日期时间型
  13. .参数 长整数型, 长整数型

  14. 置入代码 ({ 139, 69, 8, 139, 85, 12, 35, 69, 16, 35, 85, 20, 201, 194, 16, 0 })
  15. ' mov eax,[ebp+8]
  16. ' mov edx,[ebp+12]
  17. ' and eax,[ebp+16]
  18. ' and edx,[ebp+20]
  19. ' leave
  20. ' retn 16

  21. 返回 (0)


  22. .子程序 日期时间型与长整数型_位或, 长整数型, 公开
  23. .参数 日期时间型, 日期时间型
  24. .参数 长整数型, 长整数型

  25. 置入代码 ({ 139, 69, 8, 139, 85, 12, 11, 69, 16, 11, 85, 20, 201, 194, 16, 0 })
  26. ' mov eax,[ebp+8]
  27. ' mov edx,[ebp+12]
  28. ' or eax,[ebp+16]
  29. ' or edx,[ebp+20]
  30. ' leave
  31. ' retn 16

  32. 返回 (0)

  33. .子程序 日期时间型与长整数型_位异或, 长整数型, 公开
  34. .参数 日期时间型, 日期时间型
  35. .参数 长整数型, 长整数型

  36. 置入代码 ({ 139, 69, 8, 139, 85, 12, 51, 69, 16, 51, 85, 20, 201, 194, 16, 0 })
  37. ' mov eax,[ebp+8]
  38. ' mov edx,[ebp+12]
  39. ' xor eax,[ebp+16]
  40. ' xor edx,[ebp+20]
  41. ' leave
  42. ' retn 16

  43. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则