免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 28|回复: 1
收起左侧

易语言MASM置入代码日期时间型与双精度小数型IEEE754逻辑运算模块(返回日期时间型)

[复制链接]
发表于 2019-9-11 22:03:43 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1, , , 使用本模块应遵守日期时间型(IEEE754)编码规则,错误使用将会造成数据异常

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (日期时间型与双精度小数型_位与_返回日期时间型 (取现行时间 (), #pi))
  9. 输出调试文本 (日期时间型与双精度小数型_位或_返回日期时间型 (取现行时间 (), #pi))
  10. 输出调试文本 (日期时间型与双精度小数型_位异或_返回日期时间型 (取现行时间 (), #pi))





  11. .子程序 日期时间型与双精度小数型_位与_返回日期时间型, 日期时间型, 公开
  12. .参数 日期, 日期时间型
  13. .参数 小数, 双精度小数型

  14. 置入代码 ({ 139, 69, 8, 139, 85, 12, 35, 69, 16, 35, 85, 20, 201, 194, 16, 0 })
  15. ' mov eax,[ebp+8]
  16. ' mov edx,[ebp+12]
  17. ' and eax,[ebp+16]
  18. ' and edx,[ebp+20]
  19. ' leave
  20. ' retn 16

  21. 返回 ([100年1月1日])


  22. .子程序 日期时间型与双精度小数型_位或_返回日期时间型, 日期时间型, 公开
  23. .参数 日期, 日期时间型
  24. .参数 小数, 双精度小数型

  25. 置入代码 ({ 139, 69, 8, 139, 85, 12, 11, 69, 16, 11, 85, 20, 201, 194, 16, 0 })
  26. ' mov eax,[ebp+8]
  27. ' mov edx,[ebp+12]
  28. ' or eax,[ebp+16]
  29. ' or edx,[ebp+20]
  30. ' leave
  31. ' retn 16
  32. 返回 ([100年1月1日])

  33. .子程序 日期时间型与双精度小数型_位异或_返回日期时间型, 日期时间型, 公开
  34. .参数 日期, 日期时间型
  35. .参数 小数, 双精度小数型

  36. 置入代码 ({ 139, 69, 8, 139, 85, 12, 51, 69, 16, 51, 85, 20, 201, 194, 16, 0 })
  37. ' mov eax,[ebp+8]
  38. ' mov edx,[ebp+12]
  39. ' xor eax,[ebp+16]
  40. ' xor edx,[ebp+20]
  41. ' leave
  42. ' retn 16
  43. 返回 ([100年1月1日])

复制代码

相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-9-20 01:38, 100.26.182.28 , Processed in 0.499003 second(s), 29 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表