更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM置入代码64位有符号长整数型数组取绝对值/ABS运算算法计算模块 (无返回值)

[复制链接]
查看138 | 回复0 | 2019-9-16 22:01:11 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 长整数数组, 长整数型, , "0"
  9. .局部变量 字节集, 字节集
  10. .局部变量 i, 整数型

  11. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  12. 置随机数种子 ()
  13. 字节集 = 取空白字节集 (8)
  14. .计次循环首 (8, )
  15.     .计次循环首 (8, i)
  16.         字节集 [i] = 取随机数 (, )
  17.     .计次循环尾 ()
  18.     加入成员 (长整数数组, 取字节集数据 (字节集, 4, ))
  19. .计次循环尾 ()
  20. 调试输出 (长整数数组)
  21. 长整数型数组_取绝对值 (长整数数组)
  22. 调试输出 (长整数数组)

  23. .子程序 长整数型数组_取绝对值, , 公开
  24. .参数 长整数型数组, 长整数型, 参考 数组

  25. 置入代码 ({ 80, 83, 81, 82, 86, 87, 139, 117, 8, 11, 246, 117, 2, 235, 67, 139, 54, 11, 246, 117, 2, 235, 59, 139, 126, 4, 11, 255, 117, 2, 235, 50, 131, 198, 8, 51, 201, 235, 39, 139, 4, 206, 139, 84, 206, 4, 129, 250, 0, 0, 0, 128, 114, 16, 83, 81, 139, 216, 139, 202, 51, 192, 51, 210, 43, 195, 27, 209, 89, 91, 137, 4, 206, 137, 84, 206, 4, 65, 59, 207, 114, 213, 95, 94, 90, 89, 91, 88 })
  26. ' push eax
  27. ' push ebx
  28. ' push ecx
  29. ' push edx
  30. ' push esi
  31. ' push edi
  32. ' mov esi,[ebp+8]
  33. ' .if esi == 0
  34. ' jmp ASM_END
  35. ' .endif
  36. ' mov esi,[esi]
  37. ' .if esi == 0
  38. ' jmp ASM_END
  39. ' .endif
  40. ' mov edi,[esi+4]
  41. ' .if edi == 0
  42. ' jmp ASM_END
  43. ' .endif
  44. ' add esi,8
  45. ' xor ecx,ecx
  46. ' .while ecx < edi
  47. ' mov eax,[esi+ecx*8]
  48. ' mov edx,[esi+ecx*8+4]
  49. ' .if edx >= 80000000H
  50. ' push ebx
  51. ' push ecx
  52. ' mov ebx,eax
  53. ' mov ecx,edx
  54. ' xor eax,eax
  55. ' xor edx,edx
  56. ' sub eax,ebx
  57. ' sbb edx,ecx
  58. ' pop ecx
  59. ' pop ebx
  60. ' .endif
  61. ' mov [esi+ecx*8],eax
  62. ' mov [esi+ecx*8+4],edx
  63. ' inc ecx
  64. ' .endw
  65. ' ASM_END:
  66. ' pop edi
  67. ' pop esi
  68. ' pop edx
  69. ' pop ecx
  70. ' pop ebx
  71. ' pop eax

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则