更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM置入代码16位有符号短整数型数组取绝对值/ABS运算计算模块算法 (无返回值)

[复制链接]
查看135 | 回复0 | 2019-9-17 22:01:26 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 短整数型, , "0"

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. A = { 0, 1, 2, 3, 4, 5, -1, -2, -3, -4, -5, 123, -123, 12345, -12345, 23456, -23456 }
  11. 调试输出 (A)
  12. 短整数型数组_取绝对值 (A)
  13. 调试输出 (A)

  14. .子程序 短整数型数组_取绝对值, , 公开
  15. .参数 短整数型数组, 短整数型, 参考 数组

  16. 置入代码 ({ 80, 83, 81, 82, 86, 87, 139, 117, 8, 11, 246, 117, 2, 235, 52, 139, 54, 11, 246, 117, 2, 235, 44, 139, 126, 4, 11, 255, 117, 2, 235, 35, 131, 198, 8, 51, 201, 235, 24, 102, 139, 4, 78, 102, 61, 0, 128, 114, 9, 102, 139, 216, 102, 51, 192, 102, 43, 195, 102, 137, 4, 78, 65, 59, 207, 114, 228, 95, 94, 90, 89, 91, 88 })
  17. ' push eax
  18. ' push ebx
  19. ' push ecx
  20. ' push edx
  21. ' push esi
  22. ' push edi
  23. ' mov esi,[ebp+8]
  24. ' .if esi == 0
  25. ' jmp ASM_END
  26. ' .endif
  27. ' mov esi,[esi]
  28. ' .if esi == 0
  29. ' jmp ASM_END
  30. ' .endif
  31. ' mov edi,[esi+4]
  32. ' .if edi == 0
  33. ' jmp ASM_END
  34. ' .endif
  35. ' add esi,8
  36. ' xor ecx,ecx
  37. ' .while ecx < edi
  38. ' mov ax,[esi+ecx*2]
  39. ' .if ax >= 8000H
  40. ' mov bx,ax
  41. ' xor ax,ax
  42. ' sub ax,bx
  43. ' .endif
  44. ' mov [esi+ecx*2],ax
  45. ' inc ecx
  46. ' .endw
  47. ' ASM_END:
  48. ' pop edi
  49. ' pop esi
  50. ' pop edx
  51. ' pop ecx
  52. ' pop ebx;
  53. ' pop eax

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则