设为首页收藏本站帮助中心
查看: 477|回复: 0
收起左侧

易语言MASM置入代码 字节型/整数型/小数型/逻辑型/短整数型 快速等于比较(返回逻辑型)

[复制链接]
发表于 2019-9-20 11:01:30 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (快速等于_字节型 (255, 255))
  9. 输出调试文本 (快速等于_整数型 (123, 123))
  10. 输出调试文本 (快速等于_小数型 (#pi, #pi))
  11. 输出调试文本 (快速等于_逻辑型 (假, 假))
  12. 输出调试文本 (快速等于_短整数型 (12345, 12345))



  13. .子程序 快速等于_字节型, 逻辑型, 公开
  14. .参数 被比较值, 字节型
  15. .参数 比较值, 字节型

  16. 置入代码 ({ 138, 69, 8, 58, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  17. ' mov al,[ebp+8]
  18. ' .if al == [ebp+12]
  19. ' mov eax,1
  20. ' .elseif
  21. ' xor eax,eax
  22. ' .endif
  23. ' leave
  24. ' retn 8
  25. 返回 (假)

  26. .子程序 快速等于_整数型, 逻辑型, 公开
  27. .参数 被比较值, 整数型
  28. .参数 比较值, 整数型

  29. 置入代码 ({ 139, 69, 8, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  30. ' mov eax,[ebp+8]
  31. ' .if eax == [ebp+12]
  32. ' mov eax,1
  33. ' .elseif
  34. ' xor eax,eax
  35. ' .endif
  36. ' leave
  37. ' retn 8

  38. 返回 (假)

  39. .子程序 快速等于_小数型, 逻辑型, 公开
  40. .参数 被比较值, 小数型
  41. .参数 比较值, 小数型

  42. 置入代码 ({ 139, 69, 8, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  43. ' mov eax,[ebp+8]
  44. ' .if eax == [ebp+12]
  45. ' mov eax,1
  46. ' .elseif
  47. ' xor eax,eax
  48. ' .endif
  49. ' leave
  50. ' retn 8

  51. 返回 (假)

  52. .子程序 快速等于_逻辑型, 逻辑型, 公开
  53. .参数 被比较值, 逻辑型
  54. .参数 比较值, 逻辑型

  55. 置入代码 ({ 139, 69, 8, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  56. ' mov eax,[ebp+8]
  57. ' .if eax == [ebp+12]
  58. ' mov eax,1
  59. ' .elseif
  60. ' xor eax,eax
  61. ' .endif
  62. ' leave
  63. ' retn 8

  64. 返回 (假)

  65. .子程序 快速等于_短整数型, 逻辑型, 公开
  66. .参数 被比较值, 短整数型
  67. .参数 比较值, 短整数型

  68. 置入代码 ({ 102, 139, 69, 8, 102, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  69. ' mov ax,[ebp+8]
  70. ' .if ax == [ebp+12]
  71. ' mov eax,1
  72. ' .elseif
  73. ' xor eax,eax
  74. ' .endif
  75. ' leave
  76. ' retn 8
  77. 返回 (假)

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则