免扫码快速登录设为首页收藏本站帮助中心
查看: 65|回复: 0
收起左侧

MASM置入代码长整数型/日期时间型/子程序指针/双精度小数型 快速等于比较(返回逻辑型)

[复制链接]
发表于 2019-9-30 11:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 A

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 输出调试文本 (快速等于_长整数型 (1.234567890123e+018, 1.234567890123e+018))
  10. 输出调试文本 (快速等于_日期时间型 ([2019年12月31日1时1分1秒], [2019年12月31日1时1分1秒]))
  11. 输出调试文本 (快速等于_子程序指针 (&快速等于_子程序指针, &快速等于_子程序指针))
  12. 输出调试文本 (快速等于_双精度小数型 (#e, #e))



  13. .子程序 快速等于_长整数型, 逻辑型, 公开
  14. .参数 被比较值, 长整数型
  15. .参数 比较值, 长整数型

  16. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 59, 69, 16, 117, 12, 59, 85, 20, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 90, 201, 194, 16, 0 })
  17. ' push edx
  18. ' mov eax,[ebp+8]
  19. ' mov edx,[ebp+12]
  20. ' .if eax == [ebp+16] && edx == [ebp+20]
  21. ' mov eax,1
  22. ' .else
  23. ' xor eax,eax
  24. ' .endif
  25. ' pop edx
  26. ' leave
  27. ' retn 16
  28. 返回 (假)

  29. .子程序 快速等于_日期时间型, 逻辑型, 公开
  30. .参数 被比较值, 日期时间型
  31. .参数 比较值, 日期时间型

  32. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 59, 69, 16, 117, 12, 59, 85, 20, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 90, 201, 194, 16, 0 })
  33. ' push edx
  34. ' mov eax,[ebp+8]
  35. ' mov edx,[ebp+12]
  36. ' .if eax == [ebp+16] && edx == [ebp+20]
  37. ' mov eax,1
  38. ' .else
  39. ' xor eax,eax
  40. ' .endif
  41. ' pop edx
  42. ' leave
  43. ' retn 16
  44. 返回 (假)

  45. .子程序 快速等于_子程序指针, 逻辑型, 公开
  46. .参数 被比较值, 子程序指针
  47. .参数 比较值, 子程序指针

  48. 置入代码 ({ 139, 69, 8, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  49. ' mov eax,[ebp+8]
  50. ' .if eax == [ebp+12]
  51. ' mov eax,1
  52. ' .elseif
  53. ' xor eax,eax
  54. ' .endif
  55. ' leave
  56. ' retn 8

  57. 返回 (假)

  58. .子程序 快速等于_双精度小数型, 逻辑型, 公开
  59. .参数 被比较值, 双精度小数型
  60. .参数 比较值, 双精度小数型

  61. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 59, 69, 16, 117, 12, 59, 85, 20, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 90, 201, 194, 16, 0 })
  62. ' push edx
  63. ' mov eax,[ebp+8]
  64. ' mov edx,[ebp+12]
  65. ' .if eax == [ebp+16] && edx == [ebp+20]
  66. ' mov eax,1
  67. ' .else
  68. ' xor eax,eax
  69. ' .endif
  70. ' pop edx
  71. ' leave
  72. ' retn 16
  73. 返回 (假)
复制代码

相关帖子

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则