更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

MASM置入代码长整数型/日期时间型/子程序指针/双精度小数型快速赋值操作(无返回值)

[复制链接]
查看62 | 回复0 | 2019-9-25 18:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 长整数型, 长整数型
  8. .局部变量 日期时间型, 日期时间型
  9. .局部变量 子程序指针, 子程序指针
  10. .局部变量 双精度小数型, 双精度小数型

  11. 快速赋值_长整数型 (长整数型, 到长整数 (“1234567890123456789”))
  12. 输出调试文本 (长整数型)
  13. 快速赋值_日期时间型 (日期时间型, 取现行时间 ())
  14. 输出调试文本 (日期时间型)
  15. 快速赋值_子程序指针 (子程序指针, &快速赋值_子程序指针)
  16. 输出调试文本 (到整数 (子程序指针))
  17. 快速赋值_双精度小数型 (双精度小数型, #pi)
  18. 输出调试文本 (双精度小数型)

  19. .子程序 快速赋值_长整数型, , 公开
  20. .参数 被赋值的变量, 长整数型, 参考
  21. .参数 用作赋于的值, 长整数型

  22. 置入代码 ({ 80, 83, 139, 69, 8, 139, 93, 12, 137, 24, 139, 93, 16, 137, 88, 4, 91, 88 })
  23. ' push eax
  24. ' push ebx
  25. ' mov eax,[ebp+8]
  26. ' mov ebx,[ebp+12]
  27. ' mov [eax],ebx
  28. ' mov ebx,[ebp+16]
  29. ' mov [eax+4],ebx
  30. ' pop ebx
  31. ' pop eax


  32. .子程序 快速赋值_日期时间型, , 公开
  33. .参数 被赋值的变量, 日期时间型, 参考
  34. .参数 用作赋于的值, 日期时间型

  35. 置入代码 ({ 80, 83, 139, 69, 8, 139, 93, 12, 137, 24, 139, 93, 16, 137, 88, 4, 91, 88 })
  36. ' push eax
  37. ' push ebx
  38. ' mov eax,[ebp+8]
  39. ' mov ebx,[ebp+12]
  40. ' mov [eax],ebx
  41. ' mov ebx,[ebp+16]
  42. ' mov [eax+4],ebx
  43. ' pop ebx
  44. ' pop eax


  45. .子程序 快速赋值_子程序指针, , 公开
  46. .参数 被赋值的变量, 子程序指针, 参考
  47. .参数 用作赋于的值, 子程序指针

  48. 置入代码 ({ 80, 83, 139, 69, 8, 139, 93, 12, 137, 24, 91, 88 })
  49. ' push eax
  50. ' push ebx
  51. ' mov eax,[ebp+8]
  52. ' mov ebx,[ebp+12]
  53. ' mov [eax],ebx
  54. ' pop ebx
  55. ' pop eax


  56. .子程序 快速赋值_双精度小数型, , 公开
  57. .参数 被赋值的变量, 双精度小数型, 参考
  58. .参数 用作赋于的值, 双精度小数型

  59. 置入代码 ({ 80, 83, 139, 69, 8, 139, 93, 12, 137, 24, 139, 93, 16, 137, 88, 4, 91, 88 })
  60. ' push eax
  61. ' push ebx
  62. ' mov eax,[ebp+8]
  63. ' mov ebx,[ebp+12]
  64. ' mov [eax],ebx
  65. ' mov ebx,[ebp+16]
  66. ' mov [eax+4],ebx
  67. ' pop ebx
  68. ' pop eax

复制代码

相关帖子

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则