免扫码快速登录设为首页收藏本站帮助中心
查看: 120|回复: 0
收起左侧

易语言MASM置入代码字节型/整数型/小数型/逻辑型/短整数型快速交换参考变量(无返回值)

[复制链接]
发表于 2019-9-26 09:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型


  5. _临时子程序 ()
  6. 返回 (0)

  7. .子程序 _临时子程序
  8. .局部变量 字节A, 字节型
  9. .局部变量 字节B, 字节型
  10. .局部变量 整数A, 整数型
  11. .局部变量 整数B, 整数型
  12. .局部变量 小数A, 小数型
  13. .局部变量 小数B, 小数型
  14. .局部变量 逻辑A, 逻辑型
  15. .局部变量 逻辑B, 逻辑型
  16. .局部变量 短整数A, 短整数型
  17. .局部变量 短整数B, 短整数型

  18. 字节A = 123
  19. 字节B = 100
  20. 快速交换变量_字节型 (字节A, 字节B)
  21. 调试输出 (字节A, 字节B)
  22. 整数A = 1234567890
  23. 整数B = 1111111111
  24. 快速交换变量_整数型 (整数A, 整数B)
  25. 调试输出 (整数A, 整数B)
  26. 小数A = 1.234567
  27. 小数B = 3.1415926
  28. 快速交换变量_小数型 (小数A, 小数B)
  29. 调试输出 (小数A, 小数B)
  30. 逻辑A = 真
  31. 逻辑B = 假
  32. 快速交换变量_逻辑型 (逻辑A, 逻辑B)
  33. 调试输出 (逻辑A, 逻辑B)
  34. 短整数A = 12345
  35. 短整数B = 10000
  36. 快速交换变量_短整数型 (短整数A, 短整数B)
  37. 调试输出 (短整数A, 短整数B)





  38. .子程序 快速交换变量_字节型, , 公开
  39. .参数 变量1, 字节型, 参考
  40. .参数 变量2, 字节型, 参考

  41. 置入代码 ({ 96, 139, 69, 8, 139, 93, 12, 138, 8, 138, 43, 136, 40, 136, 11, 97 })
  42. ' pushad
  43. ' mov eax,[ebp+8]
  44. ' mov ebx,[ebp+12]
  45. ' mov cl,[eax]
  46. ' mov ch,[ebx]
  47. ' mov [eax],ch
  48. ' mov [ebx],cl
  49. ' popad


  50. .子程序 快速交换变量_整数型, , 公开
  51. .参数 变量1, 整数型, 参考
  52. .参数 变量2, 整数型, 参考

  53. 置入代码 ({ 96, 139, 69, 8, 139, 93, 12, 139, 8, 139, 19, 137, 16, 137, 11, 97 })
  54. ' pushad
  55. ' mov eax,[ebp+8]
  56. ' mov ebx,[ebp+12]
  57. ' mov ecx,[eax]
  58. ' mov edx,[ebx]
  59. ' mov [eax],edx
  60. ' mov [ebx],ecx
  61. ' popad


  62. .子程序 快速交换变量_小数型, , 公开
  63. .参数 变量1, 小数型, 参考
  64. .参数 变量2, 小数型, 参考

  65. 置入代码 ({ 96, 139, 69, 8, 139, 93, 12, 139, 8, 139, 19, 137, 16, 137, 11, 97 })
  66. ' pushad
  67. ' mov eax,[ebp+8]
  68. ' mov ebx,[ebp+12]
  69. ' mov ecx,[eax]
  70. ' mov edx,[ebx]
  71. ' mov [eax],edx
  72. ' mov [ebx],ecx
  73. ' popad


  74. .子程序 快速交换变量_逻辑型, , 公开
  75. .参数 变量1, 逻辑型, 参考
  76. .参数 变量2, 逻辑型, 参考

  77. 置入代码 ({ 96, 139, 69, 8, 139, 93, 12, 139, 8, 139, 19, 137, 16, 137, 11, 97 })
  78. ' pushad
  79. ' mov eax,[ebp+8]
  80. ' mov ebx,[ebp+12]
  81. ' mov ecx,[eax]
  82. ' mov edx,[ebx]
  83. ' mov [eax],edx
  84. ' mov [ebx],ecx
  85. ' popad


  86. .子程序 快速交换变量_短整数型, , 公开
  87. .参数 变量1, 短整数型, 参考
  88. .参数 变量2, 短整数型, 参考

  89. 置入代码 ({ 96, 139, 69, 8, 139, 93, 12, 102, 139, 8, 102, 139, 19, 102, 137, 16, 102, 137, 11, 97 })
  90. ' pushad
  91. ' mov eax,[ebp+8]
  92. ' mov ebx,[ebp+12]
  93. ' mov cx,[eax]
  94. ' mov dx,[ebx]
  95. ' mov [eax],dx
  96. ' mov [ebx],cx
  97. ' popad

复制代码

相关帖子

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则