更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM置入代码通过长数据+短数据长度+偏移量计算是否有效(下标0开始,返回逻辑型)

[复制链接]
查看102 | 回复0 | 2019-9-29 20:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x
本帖最后由 QAQ 于 2019-8-24 20:00 编辑

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (_偏移量是否有效 (32, 8, 32 - 8))
  9. 输出调试文本 (偏移量是否有效 (64, 22, 64 - 22))

  10. .子程序 _偏移量是否有效, 逻辑型
  11. .参数 eax, 整数型, , 长数据长度
  12. .参数 ebx, 整数型, , 短数据长度
  13. .参数 ecx, 整数型, , 偏移量 下标0开始
  14. .局部变量 esi, 整数型, , , 最大偏移量


  15. esi = eax - ebx

  16. .如果真 (esi < 0 或 ecx > esi 或 eax ≤ 0 或 ebx ≤ 0 或 ecx < 0)
  17.     返回 (假)
  18. .如果真结束





  19. 返回 (真)


  20. .子程序 偏移量是否有效, 逻辑型, 公开
  21. .参数 长数据长度, 整数型
  22. .参数 短数据长度, 整数型
  23. .参数 偏移量, 整数型, , 下标从0开始

  24. 置入代码 ({ 235, 70, 86, 139, 240, 43, 243, 178, 1, 129, 254, 0, 0, 0, 128, 114, 4, 50, 210, 235, 49, 59, 206, 118, 4, 50, 210, 235, 41, 11, 192, 116, 7, 61, 0, 0, 0, 128, 114, 4, 50, 210, 235, 26, 11, 219, 116, 8, 129, 251, 0, 0, 0, 128, 114, 4, 50, 210, 235, 10, 129, 249, 0, 0, 0, 128, 114, 2, 50, 210, 94, 195, 83, 81, 82, 139, 69, 8, 139, 93, 12, 139, 77, 16, 232, 169, 255, 255, 255, 15, 182, 194, 90, 89, 91, 201, 194, 12, 0 })
  25. ' jmp MAIN
  26. ' IOAT:
  27. ' push esi
  28. ' mov esi,eax
  29. ' sub esi,ebx
  30. ' mov dl,1
  31. ' .if esi >= 80000000H
  32. ' xor dl,dl
  33. ' .elseif ecx > esi
  34. ' xor dl,dl
  35. ' .elseif eax == 0 || eax >= 80000000H
  36. ' xor dl,dl
  37. ' .elseif ebx == 0 || ebx >= 80000000H
  38. ' xor dl,dl
  39. ' .elseif ecx >= 80000000H
  40. ' xor dl,dl
  41. ' .endif
  42. ' pop esi
  43. ' ret
  44. ' MAIN:
  45. ' push ebx
  46. ' push ecx
  47. ' push edx
  48. ' mov eax,[ebp+8]
  49. ' mov ebx,[ebp+12]
  50. ' mov ecx,[ebp+16]
  51. ' call IOAT
  52. ' movzx eax,dl
  53. ' pop edx
  54. ' pop ecx
  55. ' pop ebx
  56. ' leave
  57. ' retn 12
  58. 返回 (假)
复制代码

相关帖子

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则