免扫码快速登录设为首页收藏本站帮助中心
查看: 79|回复: 0
收起左侧

易语言MASM置入代码字节集数据转换到字节型/整数型/小数型/逻辑型/短整数型/长整数型

[复制链接]
发表于 2019-10-2 10:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (字节集_到字节 ({ 100 }))
  8. 输出调试文本 (字节集_到整数 ({ 210, 2, 150, 73 }))
  9. 输出调试文本 (字节集_到小数 ({ 219, 15, 73, 64 }))
  10. 输出调试文本 (字节集_到逻辑 ({ 1 }))
  11. 输出调试文本 (字节集_到短整数 ({ 57, 48 }))
  12. 输出调试文本 (字节集_到长整数 ({ 21, 129, 233, 125, 244, 16, 34, 17 }))


  13. .子程序 字节集_到字节, 字节型, 公开
  14. .参数 字节集, 字节集, , 1字节

  15. 置入代码 ({ 139, 69, 8, 139, 0, 138, 64, 8, 15, 182, 192, 201, 194, 4, 0 })
  16. ' mov eax,[ebp+8]
  17. ' mov eax,[eax]
  18. ' mov al,[eax+8]
  19. ' movzx eax,al
  20. ' leave
  21. ' retn 4
  22. 返回 (0)


  23. .子程序 字节集_到整数, 整数型, 公开
  24. .参数 字节集, 字节集, , 4字节

  25. 置入代码 ({ 139, 69, 8, 139, 0, 139, 64, 8, 201, 194, 4, 0 })
  26. ' mov eax,[ebp+8]
  27. ' mov eax,[eax]
  28. ' mov eax,[eax+8]
  29. ' leave
  30. ' retn 4

  31. 返回 (0)

  32. .子程序 字节集_到小数, 小数型, 公开
  33. .参数 字节集, 字节集, , 4字节

  34. 置入代码 ({ 139, 69, 8, 139, 0, 139, 64, 8, 201, 194, 4, 0 })
  35. ' mov eax,[ebp+8]
  36. ' mov eax,[eax]
  37. ' mov eax,[eax+8]
  38. ' leave
  39. ' retn 4

  40. 返回 (0)

  41. .子程序 字节集_到逻辑, 逻辑型, 公开
  42. .参数 字节集, 字节集, , 1字节 奇数为真,偶数为假

  43. 置入代码 ({ 139, 69, 8, 139, 0, 138, 64, 8, 36, 1, 15, 182, 192, 201, 194, 4, 0 })
  44. ' mov eax,[ebp+8]
  45. ' mov eax,[eax]
  46. ' mov al,[eax+8]
  47. ' and al,1
  48. ' movzx eax,al
  49. ' leave
  50. ' retn 4
  51. 返回 (假)

  52. .子程序 字节集_到短整数, 短整数型, 公开
  53. .参数 字节集, 字节集, , 2字节

  54. 置入代码 ({ 139, 69, 8, 139, 0, 102, 139, 64, 8, 15, 183, 192, 201, 194, 4, 0 })
  55. ' mov eax,[ebp+8]
  56. ' mov eax,[eax]
  57. ' mov ax,[eax+8]
  58. ' movzx eax,ax
  59. ' leave
  60. ' retn 4
  61. 返回 (0)

  62. .子程序 字节集_到长整数, 长整数型, 公开
  63. .参数 字节集, 字节集, , 8字节

  64. 置入代码 ({ 139, 85, 8, 139, 18, 139, 66, 8, 139, 82, 12, 201, 194, 4, 0 })
  65. ' mov edx,[ebp+8]
  66. ' mov edx,[edx]
  67. ' mov eax,[edx+8]
  68. ' mov edx,[edx+12]
  69. ' leave
  70. ' retn 4
  71. 返回 (0)
复制代码

相关帖子

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则