免扫码快速登录设为首页收藏本站帮助中心
查看: 95|回复: 0
收起左侧

易语言MASM汇编置入代码实现将字节集数据转换到日期时间型/子程序指针/双精度小数型

[复制链接]
发表于 2019-10-3 10:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1
  4. .程序集变量 空白指针, 子程序指针

  5. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  6. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  7. 返回 (0)  ' 可以根据您的需要返回任意数值

  8. .子程序 _临时子程序

  9. 输出调试文本 (字节集_到时间 ({ 2, 201, 58, 23, 100, 57, 229, 64 }))
  10. 调试输出 (字节集_到指针 ({ 255, 255, 255, 255 }))
  11. 输出调试文本 (字节集_到数值 ({ 68, 23, 65, 84, 251, 33, 9, 64 }))

  12. .子程序 字节集_到时间, 日期时间型, 公开
  13. .参数 字节集, 字节集, , 8字节

  14. 置入代码 ({ 139, 85, 8, 139, 18, 139, 66, 8, 139, 82, 12, 201, 194, 4, 0 })
  15. ' mov edx,[ebp+8]
  16. ' mov edx,[edx]
  17. ' mov eax,[edx+8]
  18. ' mov edx,[edx+12]
  19. ' leave
  20. ' retn 4
  21. 返回 ([100年1月1日])

  22. .子程序 字节集_到指针, 子程序指针, 公开
  23. .参数 字节集, 字节集, , 4字节

  24. 置入代码 ({ 139, 69, 8, 139, 0, 139, 64, 8, 201, 194, 4, 0 })
  25. ' mov eax,[ebp+8]
  26. ' mov eax,[eax]
  27. ' mov eax,[eax+8]
  28. ' leave
  29. ' retn 4
  30. 返回 (空白指针)


  31. .子程序 字节集_到数值, 双精度小数型, 公开
  32. .参数 字节集, 字节集, , 8字节

  33. 置入代码 ({ 139, 85, 8, 139, 18, 139, 66, 8, 139, 82, 12, 201, 194, 4, 0 })
  34. ' mov edx,[ebp+8]
  35. ' mov edx,[edx]
  36. ' mov eax,[edx+8]
  37. ' mov edx,[edx+12]
  38. ' leave
  39. ' retn 4
  40. 返回 (0)
复制代码

相关帖子

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则