更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM置入代码将字节集/字节型数组转换到有符号短整数型数组(-128~127,无返回值)

[复制链接]
查看94 | 回复0 | 2019-10-7 17:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 字节集, 字节集
  9. .局部变量 字节型数组, 字节型, , "256"
  10. .局部变量 短整数型数组, 短整数型, , "0"
  11. .局部变量 计数, 整数型

  12. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  13. 字节集 = 取空白字节集 (256)
  14. .计次循环首 (256, 计数)
  15.     字节集 [计数] = 计数 - 1
  16.     字节型数组 [计数] = 计数 - 1
  17. .计次循环尾 ()
  18. 字节集_到有符号短整数型数组 (字节集, 短整数型数组)
  19. 调试输出 (字节集)
  20. 调试输出 (字节型数组)

  21. 字节型数组_到有符号短整数型数组 (字节型数组, 短整数型数组)

  22. 调试输出 (字节型数组)
  23. 调试输出 (短整数型数组)

  24. .子程序 字节集_到有符号短整数型数组, , 公开
  25. .参数 字节集, 字节集
  26. .参数 短整数型数组, 短整数型, 参考 数组

  27. 重定义数组 (短整数型数组, 真, 取字节集长度 (字节集))
  28. 置入代码 ({ 80, 83, 81, 87, 86, 87, 139, 69, 8, 11, 192, 117, 2, 235, 56, 139, 0, 11, 192, 117, 2, 235, 48, 139, 88, 4, 11, 219, 116, 8, 129, 251, 0, 0, 0, 128, 114, 2, 235, 31, 131, 192, 8, 139, 77, 12, 139, 9, 131, 193, 8, 51, 246, 235, 12, 138, 20, 48, 102, 15, 190, 210, 102, 137, 20, 113, 70, 59, 243, 114, 240, 95, 94, 90, 89, 91, 88 })
  29. ' push eax
  30. ' push ebx
  31. ' push ecx
  32. ' push edi
  33. ' push esi
  34. ' push edi
  35. ' mov eax,[ebp+8]
  36. ' .if eax == 0
  37. ' jmp ASM_END
  38. ' .endif
  39. ' mov eax,[eax]
  40. ' .if eax == 0
  41. ' jmp ASM_END
  42. ' .endif
  43. ' mov ebx,[eax+4]
  44. ' .if ebx == 0 || ebx >= 80000000H
  45. ' jmp ASM_END
  46. ' .endif
  47. ' add eax,8
  48. ' mov ecx,[ebp+12]
  49. ' mov ecx,[ecx]
  50. ' add ecx,8
  51. ' xor esi,esi
  52. ' .while esi < ebx
  53. ' mov dl,[esi+eax]
  54. ' movsx dx,dl
  55. ' mov [ecx+esi*2],dx
  56. ' inc esi
  57. ' .endw
  58. ' ASM_END:
  59. ' pop edi
  60. ' pop esi
  61. ' pop edx
  62. ' pop ecx
  63. ' pop ebx
  64. ' pop eax


  65. .子程序 字节型数组_到有符号短整数型数组, , 公开
  66. .参数 字节型数组, 字节型, 数组
  67. .参数 短整数型数组, 短整数型, 参考 数组

  68. 重定义数组 (短整数型数组, 真, 取数组成员数 (字节型数组))
  69. 置入代码 ({ 80, 83, 81, 87, 86, 87, 139, 69, 8, 11, 192, 117, 2, 235, 56, 139, 0, 11, 192, 117, 2, 235, 48, 139, 88, 4, 11, 219, 116, 8, 129, 251, 0, 0, 0, 128, 114, 2, 235, 31, 131, 192, 8, 139, 77, 12, 139, 9, 131, 193, 8, 51, 246, 235, 12, 138, 20, 48, 102, 15, 190, 210, 102, 137, 20, 113, 70, 59, 243, 114, 240, 95, 94, 90, 89, 91, 88 })
  70. ' push eax
  71. ' push ebx
  72. ' push ecx
  73. ' push edi
  74. ' push esi
  75. ' push edi
  76. ' mov eax,[ebp+8]
  77. ' .if eax == 0
  78. ' jmp ASM_END
  79. ' .endif
  80. ' mov eax,[eax]
  81. ' .if eax == 0
  82. ' jmp ASM_END
  83. ' .endif
  84. ' mov ebx,[eax+4]
  85. ' .if ebx == 0 || ebx >= 80000000H
  86. ' jmp ASM_END
  87. ' .endif
  88. ' add eax,8
  89. ' mov ecx,[ebp+12]
  90. ' mov ecx,[ecx]
  91. ' add ecx,8
  92. ' xor esi,esi
  93. ' .while esi < ebx
  94. ' mov dl,[esi+eax]
  95. ' movsx dx,dl
  96. ' mov [ecx+esi*2],dx
  97. ' inc esi
  98. ' .endw
  99. ' ASM_END:
  100. ' pop edi
  101. ' pop esi
  102. ' pop edx
  103. ' pop ecx
  104. ' pop ebx
  105. ' pop eax

复制代码

相关帖子

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则