更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM置入代码短整数型数组所有成员参与位与、位或、位异或运算(返回短整数型)

[复制链接]
查看129 | 回复0 | 2019-10-9 18:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (短整数型数组_位与 ({ -1, 255, 31, 16 }))
  10. 调试输出 (短整数型数组_位或 ({ 255, 31, 16, 12345, 23456 }))
  11. 调试输出 (短整数型数组_位异或 ({ 255, 31, 16, 12345, 23456 }))




  12. .子程序 短整数型数组_位与, 短整数型, 公开
  13. .参数 短整数数组, 短整数型, 数组

  14. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 49, 139, 0, 11, 192, 117, 2, 235, 41, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 30, 131, 192, 8, 51, 201, 102, 186, 255, 255, 235, 12, 102, 35, 20, 72, 102, 11, 210, 117, 2, 235, 5, 65, 59, 203, 114, 240, 15, 183, 194, 90, 89, 91, 201, 194, 4, 0 })
  15. ' push ebx
  16. ' push ecx
  17. ' push edx
  18. ' mov eax,[ebp+8]
  19. ' .if eax == 0
  20. ' jmp ASM_END
  21. ' .endif
  22. ' mov eax,[eax]
  23. ' .if eax == 0
  24. ' jmp ASM_END
  25. ' .endif
  26. ' mov ebx,[eax+4]
  27. ' .if ebx == 0
  28. ' xor eax,eax
  29. ' jmp ASM_END
  30. ' .endif
  31. ' add eax,8
  32. ' xor ecx,ecx
  33. ' mov dx,-1
  34. ' .while ecx < ebx
  35. ' and dx,[eax+ecx*2]
  36. ' .if dx == 0
  37. ' .break
  38. ' .endif
  39. ' inc ecx
  40. ' .endw
  41. ' movzx eax,dx
  42. ' ASM_END:
  43. ' pop edx
  44. ' pop ecx
  45. ' pop ebx
  46. ' leave
  47. ' retn 4

  48. 返回 (0)

  49. .子程序 短整数型数组_位或, 短整数型, 公开
  50. .参数 短整数数组, 短整数型, 数组

  51. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 49, 139, 0, 11, 192, 117, 2, 235, 41, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 30, 131, 192, 8, 51, 201, 102, 51, 210, 235, 13, 102, 11, 20, 72, 102, 131, 250, 255, 117, 2, 235, 5, 65, 59, 203, 114, 239, 15, 183, 194, 90, 89, 91, 201, 194, 4, 0 })
  52. ' push ebx
  53. ' push ecx
  54. ' push edx
  55. ' mov eax,[ebp+8]
  56. ' .if eax == 0
  57. ' jmp ASM_END
  58. ' .endif
  59. ' mov eax,[eax]
  60. ' .if eax == 0
  61. ' jmp ASM_END
  62. ' .endif
  63. ' mov ebx,[eax+4]
  64. ' .if ebx == 0
  65. ' xor eax,eax
  66. ' jmp ASM_END
  67. ' .endif
  68. ' add eax,8
  69. ' xor ecx,ecx
  70. ' xor dx,dx
  71. ' .while ecx < ebx
  72. ' or dx,[eax+ecx*2]
  73. ' .if dx == 65535
  74. ' .break
  75. ' .endif
  76. ' inc ecx
  77. ' .endw
  78. ' movzx eax,dx
  79. ' ASM_END:
  80. ' pop edx
  81. ' pop ecx
  82. ' pop ebx
  83. ' leave
  84. ' retn 4

  85. 返回 (0)

  86. .子程序 短整数型数组_位异或, 短整数型, 公开
  87. .参数 短整数数组, 短整数型, 数组

  88. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 41, 139, 0, 11, 192, 117, 2, 235, 33, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 22, 131, 192, 8, 51, 201, 102, 51, 210, 235, 5, 102, 51, 20, 72, 65, 59, 203, 114, 247, 15, 183, 194, 90, 89, 91, 201, 194, 4, 0 })
  89. ' push ebx
  90. ' push ecx
  91. ' push edx
  92. ' mov eax,[ebp+8]
  93. ' .if eax == 0
  94. ' jmp ASM_END
  95. ' .endif
  96. ' mov eax,[eax]
  97. ' .if eax == 0
  98. ' jmp ASM_END
  99. ' .endif
  100. ' mov ebx,[eax+4]
  101. ' .if ebx == 0
  102. ' xor eax,eax
  103. ' jmp ASM_END
  104. ' .endif
  105. ' add eax,8
  106. ' xor ecx,ecx
  107. ' xor dx,dx
  108. ' .while ecx < ebx
  109. ' xor dx,[eax+ecx*2]
  110. ' inc ecx
  111. ' .endw
  112. ' movzx eax,dx
  113. ' ASM_END:
  114. ' pop edx
  115. ' pop ecx
  116. ' pop ebx
  117. ' leave
  118. ' retn 4

  119. 返回 (0)
复制代码

相关帖子

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则