更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM置入代码整数型数组与一个整数型常数常量的位与/位或/位异或运算(无返回值)

[复制链接]
查看96 | 回复0 | 2019-10-12 20:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 整数型数组, 整数型, , "0"



  9. 整数型数组 = { 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15 }
  10. 整数型数组_位与_常数 (整数型数组, 3)
  11. 调试输出 (整数型数组)
  12. 整数型数组 = { 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15 }
  13. 整数型数组_位或_常数 (整数型数组, 128)
  14. 调试输出 (整数型数组)
  15. 整数型数组 = { 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15 }
  16. 整数型数组_位异或_常数 (整数型数组, 1)
  17. 调试输出 (整数型数组)


  18. .子程序 整数型数组_位与_常数, , 公开, 数组所有成员与一个整数位运算,结果送回数组
  19. .参数 位运算数组, 整数型, 参考 数组, 位运算结果将通过数组变量传出
  20. .参数 位运算常数, 整数型, , 数组所有成员与该值参与位运算

  21. 置入代码 ({ 80, 81, 86, 87, 139, 69, 12, 131, 248, 255, 117, 2, 235, 35, 139, 117, 8, 11, 246, 117, 2, 235, 26, 139, 54, 11, 246, 117, 2, 235, 18, 139, 126, 4, 131, 198, 8, 51, 201, 235, 4, 33, 4, 142, 65, 59, 207, 114, 248, 95, 94, 89, 88 })
  22. ' push eax
  23. ' push ecx
  24. ' push esi
  25. ' push edi
  26. ' mov eax,[ebp+12]
  27. ' .if eax == -1
  28. ' jmp ASM_END
  29. ' .endif
  30. ' mov esi,[ebp+8]
  31. ' .if esi == 0
  32. ' jmp ASM_END
  33. ' .endif
  34. ' mov esi,[esi]
  35. ' .if esi == 0
  36. ' jmp ASM_END
  37. ' .endif
  38. ' mov edi,[esi+4]
  39. ' add esi,8
  40. ' xor ecx,ecx
  41. ' .while ecx < edi
  42. ' and [esi+ecx*4],eax
  43. ' inc ecx
  44. ' .endw
  45. ' ASM_END:
  46. ' pop edi
  47. ' pop esi
  48. ' pop ecx
  49. ' pop eax


  50. .子程序 整数型数组_位或_常数, , 公开, 数组所有成员与一个整数位运算,结果送回数组
  51. .参数 位运算数组, 整数型, 参考 数组, 位运算结果将通过数组变量传出
  52. .参数 位运算常数, 整数型, , 数组所有成员与该值参与位运算

  53. 置入代码 ({ 80, 81, 86, 87, 139, 69, 12, 11, 192, 117, 2, 235, 35, 139, 117, 8, 11, 246, 117, 2, 235, 26, 139, 54, 11, 246, 117, 2, 235, 18, 139, 126, 4, 131, 198, 8, 51, 201, 235, 4, 9, 4, 142, 65, 59, 207, 114, 248, 95, 94, 89, 88 })
  54. ' push eax
  55. ' push ecx
  56. ' push esi
  57. ' push edi
  58. ' mov eax,[ebp+12]
  59. ' .if eax == 0
  60. ' jmp ASM_END
  61. ' .endif
  62. ' mov esi,[ebp+8]
  63. ' .if esi == 0
  64. ' jmp ASM_END
  65. ' .endif
  66. ' mov esi,[esi]
  67. ' .if esi == 0
  68. ' jmp ASM_END
  69. ' .endif
  70. ' mov edi,[esi+4]
  71. ' add esi,8
  72. ' xor ecx,ecx
  73. ' .while ecx < edi
  74. ' or [esi+ecx*4],eax
  75. ' inc ecx
  76. ' .endw
  77. ' ASM_END:
  78. ' pop edi
  79. ' pop esi
  80. ' pop ecx
  81. ' pop eax


  82. .子程序 整数型数组_位异或_常数, , 公开, 数组所有成员与一个整数位运算,结果送回数组
  83. .参数 位运算数组, 整数型, 参考 数组, 位运算结果将通过数组变量传出
  84. .参数 位运算常数, 整数型, , 数组所有成员与该值参与位运算

  85. 置入代码 ({ 80, 81, 86, 87, 139, 69, 12, 11, 192, 117, 2, 235, 35, 139, 117, 8, 11, 246, 117, 2, 235, 26, 139, 54, 11, 246, 117, 2, 235, 18, 139, 126, 4, 131, 198, 8, 51, 201, 235, 4, 49, 4, 142, 65, 59, 207, 114, 248, 95, 94, 89, 88 })
  86. ' push eax
  87. ' push ecx
  88. ' push esi
  89. ' push edi
  90. ' mov eax,[ebp+12]
  91. ' .if eax == 0
  92. ' jmp ASM_END
  93. ' .endif
  94. ' mov esi,[ebp+8]
  95. ' .if esi == 0
  96. ' jmp ASM_END
  97. ' .endif
  98. ' mov esi,[esi]
  99. ' .if esi == 0
  100. ' jmp ASM_END
  101. ' .endif
  102. ' mov edi,[esi+4]
  103. ' add esi,8
  104. ' xor ecx,ecx
  105. ' .while ecx < edi
  106. ' xor [esi+ecx*4],eax
  107. ' inc ecx
  108. ' .endw
  109. ' ASM_END:
  110. ' pop edi
  111. ' pop esi
  112. ' pop ecx
  113. ' pop eax

复制代码

相关帖子

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则