免扫码快速登录设为首页收藏本站帮助中心
查看: 154|回复: 0
收起左侧

易语言MASM置入代码整数型数值的无符号逻辑右移 (解决核心库自带有符号算数右移出错)

[复制链接]
发表于 2019-9-8 08:32:17 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 检查 (右移 (-1234567890, 13) = 无符号右移 (-1234567890, 13))
  9. 检查 (右移 (1234567890, 13) = 无符号右移 (1234567890, 13))



  10. .子程序 无符号右移, 整数型, 公开, 无符号(逻辑)右移左边补0,有符号(算数)右移左边补符号位
  11. .参数 欲移动的整数, 整数型, , 易语言自带的右移为有符号右移,与无符号右移计算结果不同
  12. .参数 欲移动的位数, 字节型, , 右移范围0~31

  13. 置入代码 ({ 102, 81, 139, 69, 8, 138, 77, 12, 211, 232, 102, 89, 201, 194, 8, 0 })
  14. ' push cx
  15. ' mov eax,[ebp+8]
  16. ' mov cl,[ebp+12]
  17. ' shr eax,cl
  18. ' pop cx
  19. ' leave
  20. ' retn 8
  21. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则