更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 82|回复: 0
收起左侧

易语言MASM置入代码整数型的无符号大于/小于/大于等于/小于等于大小比较 (返回逻辑型)

[复制链接]
发表于 2019-10-15 10:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (大于_无符号 (123, 100), 123 > 100)
  10. 调试输出 (大于_无符号 (-123, 100), -123 > 100)
  11. 调试输出 (小于_无符号 (123, 100), 123 < 100)
  12. 调试输出 (小于_无符号 (-123, 100), -123 < 100)



  13. .子程序 大于_无符号, 逻辑型, 公开
  14. .参数 被比较值, 整数型
  15. .参数 比较值, 整数型

  16. 置入代码 ({ 139, 69, 8, 59, 69, 12, 118, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  17. ' mov eax,[ebp+8]
  18. ' .if eax > [ebp+12]
  19. ' mov eax,1
  20. ' .else
  21. ' xor eax,eax
  22. ' .endif
  23. ' leave
  24. ' retn 8
  25. 返回 (假)


  26. .子程序 大于等于_无符号, 逻辑型, 公开
  27. .参数 被比较值, 整数型
  28. .参数 比较值, 整数型

  29. 置入代码 ({ 139, 69, 8, 59, 69, 12, 114, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  30. ' mov eax,[ebp+8]
  31. ' .if eax >= [ebp+12]
  32. ' mov eax,1
  33. ' .else
  34. ' xor eax,eax
  35. ' .endif
  36. ' leave
  37. ' retn 8
  38. 返回 (假)

  39. .子程序 小于_无符号, 逻辑型, 公开
  40. .参数 被比较值, 整数型
  41. .参数 比较值, 整数型

  42. 置入代码 ({ 139, 69, 8, 59, 69, 12, 115, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  43. ' mov eax,[ebp+8]
  44. ' .if eax < [ebp+12]
  45. ' mov eax,1
  46. ' .else
  47. ' xor eax,eax
  48. ' .endif
  49. ' leave
  50. ' retn 8
  51. 返回 (假)



  52. .子程序 小于等于_无符号, 逻辑型, 公开
  53. .参数 被比较值, 整数型
  54. .参数 比较值, 整数型

  55. 置入代码 ({ 139, 69, 8, 59, 69, 12, 119, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  56. ' mov eax,[ebp+8]
  57. ' .if eax <= [ebp+12]
  58. ' mov eax,1
  59. ' .else
  60. ' xor eax,eax
  61. ' .endif
  62. ' leave
  63. ' retn 8

  64. 返回 (假)
复制代码

相关帖子

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则