更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM置入代码检测1个整数型占多少个字节 0~255返回1,256~65535返回2 (以此类推)

[复制链接]
查看91 | 回复0 | 2019-10-17 19:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 计数, 整数型

  9. .判断循环首 (真)
  10.     调试输出 (计数, 取整数占用字节数 (计数))
  11.     计数 = 计数 + 1
  12. .判断循环尾 ()


  13. .子程序 取整数占用字节数, 字节型, 公开, 0~255返回1,256~65535返回2,65536~16777215返回3,16777216以上,负数返回4
  14. .参数 整数型, 整数型

  15. 置入代码 ({ 139, 69, 8, 61, 0, 1, 0, 0, 115, 7, 184, 1, 0, 0, 0, 235, 33, 61, 0, 0, 1, 0, 115, 7, 184, 2, 0, 0, 0, 235, 19, 61, 0, 0, 0, 1, 115, 7, 184, 3, 0, 0, 0, 235, 5, 184, 4, 0, 0, 0, 201, 194, 4, 0 })
  16. ' mov eax,[ebp+8]
  17. ' .if eax < 256
  18. ' mov eax,1
  19. ' .elseif eax < 65536
  20. ' mov eax,2
  21. ' .elseif eax < 16777216
  22. ' mov eax,3
  23. ' .else
  24. ' mov eax,4
  25. ' .endif
  26. ' leave
  27. ' retn 4
  28. 返回 (0)
复制代码

相关帖子

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则