免扫码快速登录设为首页收藏本站帮助中心
查看: 54|回复: 2
收起左侧

易语言MASM置入代码调用汇编cpuid指令实现获取CPU详细参数信息 (无返回值)

[复制链接]
发表于 2019-11-9 10:07:37 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 eax, 整数型
  9. .局部变量 ebx, 整数型
  10. .局部变量 ecx, 整数型
  11. .局部变量 edx, 整数型


  12. eax = 1
  13. cpuid (eax, ebx, ecx, edx)
  14. 调试输出 (eax, ebx, ecx, edx)


  15. .子程序 cpuid, , 公开
  16. .参数 eax, 整数型, 参考
  17. .参数 ebx, 整数型, 参考
  18. .参数 ecx, 整数型, 参考
  19. .参数 edx, 整数型, 参考

  20. 置入代码 ({ 80, 83, 81, 82, 86, 139, 69, 8, 139, 93, 12, 139, 77, 16, 139, 85, 20, 139, 0, 139, 27, 139, 9, 139, 18, 15, 162, 139, 117, 8, 137, 6, 139, 117, 12, 137, 30, 139, 117, 16, 137, 14, 139, 117, 20, 137, 22, 94, 90, 89, 91, 88 })
  21. ' push eax
  22. ' push ebx
  23. ' push ecx
  24. ' push edx
  25. ' push esi
  26. ' mov eax,[ebp+8]
  27. ' mov ebx,[ebp+12]
  28. ' mov ecx,[ebp+16]
  29. ' mov edx,[ebp+20]
  30. ' mov eax,[eax]
  31. ' mov ebx,[ebx]
  32. ' mov ecx,[ecx]
  33. ' mov edx,[edx]
  34. ' cpuid
  35. ' mov esi,[ebp+8]
  36. ' mov [esi],eax
  37. ' mov esi,[ebp+12]
  38. ' mov [esi],ebx
  39. ' mov esi,[ebp+16]
  40. ' mov [esi],ecx
  41. ' mov esi,[ebp+20]
  42. ' mov [esi],edx
  43. ' pop esi
  44. ' pop edx
  45. ' pop ecx
  46. ' pop ebx
  47. ' pop eax


复制代码

相关帖子

回复

使用道具 举报

发表于 2019-11-10 16:21:05 | 显示全部楼层
Orange 发表于 2019-11-9 18:38
看不懂是做什么的

我也没看懂
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则