免扫码快速登录设为首页收藏本站帮助中心
查看: 53|回复: 0
收起左侧

易语言MASM置入代码执行调用汇编cpuid指令实现获取CPU全球唯一序列号 (返回长整数型)

[复制链接]
发表于 2019-11-10 19:39:03 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (取CPU序列号 ())


  9. .子程序 取CPU序列号, 长整数型, 公开, 转换前注意大小端

  10. 置入代码 ({ 83, 81, 184, 1, 0, 0, 0, 15, 162, 89, 91, 201, 195 })
  11. ' push ebx
  12. ' push ecx
  13. ' mov eax,1
  14. ' cpuid
  15. ' pop ecx
  16. ' pop ebx
  17. ' leave
  18. ' retn

  19. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则