每日签到免扫码快速登录设为首页收藏本站帮助中心
查看: 116|回复: 0
收起左侧

易语言MASM置入代码判断文本型字符串是否全部为有效大小写字母+数字组成 (返回逻辑型)

[复制链接]

签到天数: 7 天

[LV.3]偶尔看看II

发表于 2019-11-15 21:08 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序


  7. 输出调试文本 (文本型_是否为大小写字母或数字 (“Abc123DEF456”))
  8. 输出调试文本 (文本型_是否为大小写字母或数字 (“Abc@Test”))
  9. 输出调试文本 (文本型_是否为大小写字母或数字 (“HelloWorld”))
  10. 输出调试文本 (文本型_是否为大小写字母或数字 (“HelloWorld!”))
  11. 输出调试文本 (文本型_是否为大小写字母或数字 (“中文”))

  12. .子程序 文本型_是否为大小写字母或数字, 逻辑型, 公开, 文本所有字符串为大小写字母或数字(Base62编码)返回真(不包括空格)
  13. .参数 字符串, 文本型, , 请勿提交空文本,否则可能会崩溃

  14. 置入代码 ({ 83, 139, 69, 8, 139, 0, 138, 24, 10, 219, 117, 4, 235, 45, 235, 40, 128, 251, 48, 114, 7, 128, 251, 57, 119, 2, 235, 28, 128, 251, 65, 114, 7, 128, 251, 90, 119, 2, 235, 16, 128, 251, 97, 114, 7, 128, 251, 122, 119, 2, 235, 4, 51, 192, 235, 8, 64, 235, 203, 184, 1, 0, 0, 0, 91, 201, 194, 4, 0 })
  15. ' push ebx
  16. ' mov eax,[ebp+8]
  17. ' mov eax,[eax]
  18. ' .while 1
  19. ' mov bl,[eax]
  20. ' .if bl == 0
  21. ' .break
  22. ' .elseif bl >= 48 && bl <= 57
  23. ' .elseif bl >= 65 && bl <= 90
  24. ' .elseif bl >= 97 && bl <=122
  25. ' .else
  26. ' xor eax,eax
  27. ' jmp ASM_END
  28. ' .endif
  29. ' inc eax
  30. ' .endw
  31. ' mov eax,1
  32. ' ASM_END:
  33. ' pop ebx
  34. ' leave
  35. ' retn 4
  36. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则