每日签到免扫码快速登录设为首页收藏本站帮助中心
查看: 140|回复: 1
收起左侧

易语言MASM置入代码判断文本型Base64编码字符串是否为有效,包含非法字符 (返回逻辑型)

[复制链接]

签到天数: 7 天

[LV.3]偶尔看看II

发表于 2019-11-16 20:01 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。


  8. 输出调试文本 (文本型_是否为有效Base64编码 (“AAECAwQFBgcICQoLDA0ODw==”))
  9. 输出调试文本 (文本型_是否为有效Base64编码 (“/=+”))
  10. 输出调试文本 (文本型_是否为有效Base64编码 (“@”))
  11. 输出调试文本 (文本型_是否为有效Base64编码 (“/w==”))
  12. 输出调试文本 (文本型_是否为有效Base64编码 (“”))




  13. .子程序 文本型_是否为有效Base64编码, 逻辑型, 公开, 检查Base64编码文本中是否包含非法字符
  14. .参数 字符串, 文本型, , 空文本返回假

  15. 置入代码 ({ 83, 82, 139, 69, 8, 11, 192, 117, 2, 235, 91, 139, 0, 11, 192, 117, 2, 235, 83, 139, 208, 138, 24, 10, 219, 117, 4, 235, 62, 235, 57, 128, 251, 48, 114, 7, 128, 251, 57, 119, 2, 235, 45, 128, 251, 65, 114, 7, 128, 251, 90, 119, 2, 235, 33, 128, 251, 97, 114, 7, 128, 251, 122, 119, 2, 235, 21, 128, 251, 43, 116, 10, 128, 251, 47, 116, 5, 128, 251, 61, 117, 2, 235, 4, 51, 192, 235, 14, 64, 235, 186, 43, 194, 11, 192, 116, 5, 184, 1, 0, 0, 0, 90, 91, 201, 194, 4, 0 })
  16. ' push ebx
  17. ' push edx
  18. ' mov eax,[ebp+8]
  19. ' .if eax == 0
  20. ' jmp ASM_END
  21. ' .endif
  22. ' mov eax,[eax]
  23. ' .if eax == 0
  24. ' jmp ASM_END
  25. ' .endif
  26. ' mov edx,eax
  27. ' .while 1
  28. ' mov bl,[eax]
  29. ' .if bl == 0
  30. ' .break
  31. ' .elseif bl >= 48 && bl <= 57
  32. ' .elseif bl >= 65 && bl <= 90
  33. ' .elseif bl >= 97 && bl <=122
  34. ' .elseif bl == 43 || bl == 47 || bl == 61
  35. ' .else
  36. ' xor eax,eax
  37. ' jmp ASM_END
  38. ' .endif
  39. ' inc eax
  40. ' .endw
  41. ' sub eax,edx
  42. ' .if eax != 0
  43. ' mov eax,1
  44. ' .endif
  45. ' ASM_END:
  46. ' pop edx
  47. ' pop ebx
  48. ' leave
  49. ' retn 4
  50. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则