设为首页收藏本站帮助中心
查看: 487|回复: 0
收起左侧

易语言MASM置入代码判断文本型是否为有效16进制编码HEX字符串(不分大小写,返回逻辑型)

[复制链接]
发表于 2019-11-17 22:03:03 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。


  8. 输出调试文本 (文本型_是否为有效16进制 (“0123456789ABCDEF”))
  9. 输出调试文本 (文本型_是否为有效16进制 (“0123456789abcdef”))
  10. 输出调试文本 (文本型_是否为有效16进制 (“0123456789abcdefg”))
  11. 输出调试文本 (文本型_是否为有效16进制 (“”))







  12. .子程序 文本型_是否为有效16进制, 逻辑型, 公开, 字符串允许出现的字符:0~9 A~F a~f 出现其他字符将返回假。
  13. .参数 字符串, 文本型, , 不分大小写,空文本返回假

  14. 置入代码 ({ 83, 82, 139, 69, 8, 11, 192, 117, 2, 235, 74, 139, 0, 11, 192, 117, 2, 235, 66, 139, 208, 138, 24, 10, 219, 117, 4, 235, 45, 235, 40, 128, 251, 48, 114, 7, 128, 251, 57, 119, 2, 235, 28, 128, 251, 65, 114, 7, 128, 251, 70, 119, 2, 235, 16, 128, 251, 97, 114, 7, 128, 251, 102, 119, 2, 235, 4, 51, 192, 235, 14, 64, 235, 203, 43, 194, 11, 192, 116, 5, 184, 1, 0, 0, 0, 90, 91, 201, 194, 4, 0 })
  15. ' push ebx
  16. ' push edx
  17. ' mov eax,[ebp+8]
  18. ' .if eax == 0
  19. ' jmp ASM_END
  20. ' .endif
  21. ' mov eax,[eax]
  22. ' .if eax == 0
  23. ' jmp ASM_END
  24. ' .endif
  25. ' mov edx,eax
  26. ' .while 1
  27. ' mov bl,[eax]
  28. ' .if bl == 0
  29. ' .break
  30. ' .elseif bl >= 48 && bl <= 57
  31. ' .elseif bl >= 65 && bl <= 70
  32. ' .elseif bl >= 97 && bl <=102
  33. ' .else
  34. ' xor eax,eax
  35. ' jmp ASM_END
  36. ' .endif
  37. ' inc eax
  38. ' .endw
  39. ' sub eax,edx
  40. ' .if eax != 0
  41. ' mov eax,1
  42. ' .endif
  43. ' ASM_END:
  44. ' pop edx
  45. ' pop ebx
  46. ' leave
  47. ' retn 4


  48. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则