设为首页收藏本站帮助中心
查看: 469|回复: 1
收起左侧

易语言MASM置入代码实现计算文本型字符串的校验和 所有字节值代码加起来 (返回字节型)

[复制链接]
发表于 2019-11-23 11:56:39 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (文本型_取校验和 (到文本 ({ 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 })))
  9. 输出调试文本 (文本型_取校验和 (“Hello World!中文测试”))



  10. .子程序 文本型_取校验和, 字节型, 公开
  11. .参数 文本, 文本型

  12. 置入代码 ({ 83, 139, 69, 8, 11, 192, 117, 2, 235, 26, 139, 0, 11, 192, 117, 2, 235, 18, 50, 255, 138, 24, 10, 219, 117, 2, 235, 5, 2, 251, 64, 235, 243, 15, 182, 199, 91, 201, 194, 4, 0 })
  13. ' push ebx
  14. ' mov eax,[ebp+8]
  15. ' .if eax == 0
  16. ' jmp ASM_END
  17. ' .endif
  18. ' mov eax,[eax]
  19. ' .if eax == 0
  20. ' jmp ASM_END
  21. ' .endif
  22. ' xor bh,bh
  23. ' .while 1
  24. ' mov bl,[eax]
  25. ' .if bl == 0
  26. ' .break
  27. ' .endif
  28. ' add bh,bl
  29. ' inc eax
  30. ' .endw
  31. ' movzx eax,bh
  32. ' ASM_END:
  33. ' pop ebx
  34. ' leave
  35. ' retn 4

  36. 返回 (0)

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则