免扫码快速登录设为首页收藏本站帮助中心 本站已运行
查看: 12|回复: 0
收起左侧

易语言MASM置入代码获取1个GBK汉字或1字节半角符号的Alt+小键盘数字编码 (返回整数型)

[复制链接]
发表于 2019-11-28 23:37:56 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (取代码2 (“易”))
  9. 输出调试文本 (取代码2 (“0”))
  10. 输出调试文本 (取代码2 (“@”))
  11. 输出调试文本 (取代码2 (“一”))

  12. .子程序 取代码2, 整数型, 公开, Alt+小键盘输入返回的数字即可打出指定汉字(失败返回0,最大65535)
  13. .参数 文本, 文本型, , 1个汉字或全角字符,或1个半角字母(最多2字节)

  14. 置入代码 ({ 83, 139, 69, 8, 11, 192, 117, 2, 235, 38, 139, 0, 11, 192, 117, 2, 235, 30, 102, 139, 24, 10, 219, 117, 4, 51, 192, 235, 19, 134, 223, 128, 251, 128, 115, 9, 128, 255, 128, 115, 4, 102, 193, 235, 8, 15, 183, 195, 91, 201, 194, 4, 0 })
  15. ' push ebx
  16. ' mov eax,[ebp+8]
  17. ' .if eax == 0
  18. ' jmp ASM_END
  19. ' .endif
  20. ' mov eax,[eax]
  21. ' .if eax == 0
  22. ' jmp ASM_END
  23. ' .endif
  24. ' mov bx,[eax]
  25. ' .if bl == 0
  26. ' xor eax,eax
  27. ' jmp ASM_END
  28. ' .endif
  29. ' xchg bl,bh
  30. ' .if bl < 128 && bh <128
  31. ' shr bx,8
  32. ' .endif
  33. ' movzx eax,bx
  34. ' ASM_END:
  35. ' pop ebx
  36. ' leave
  37. ' retn 4

  38. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则