设为首页收藏本站帮助中心
查看: 416|回复: 0
收起左侧

易语言 增强分割文本2.0 用作分割的文本可为文本型数组 (可使用多种分隔符分割字符串)

[复制链接]
发表于 2020-1-12 18:59:24 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.PNG

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  5. 置随机数种子 ()
  6. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  7. 返回 (0)  ' 可以根据您的需要返回任意数值

  8. .子程序 _临时子程序
  9. .局部变量 返回值, 文本型, , "0"



  10. 分割文本2 (“1,2|3!4@5@6@7”, { “,”, “#”, “|”, “!”, “@” }, , 返回值)
  11. 调试输出 (返回值)



  12. .子程序 分割文本2, , 公开
  13. .参数 待分割文本, 文本型
  14. .参数 用作分割的文本数组, 文本型, 数组
  15. .参数 要返回的子文本数目, 整数型, 可空
  16. .参数 返回值, 文本型, 数组
  17. .局部变量 待分割文本副本, 文本型
  18. .局部变量 随机文本, 文本型
  19. .局部变量 随机数据, 字节集
  20. .局部变量 计数, 整数型

  21. 待分割文本副本 = 待分割文本
  22. 随机数据 = 取空白字节集 (256)
  23. .计次循环首 (256, 计数)
  24.     随机数据 [计数] = 取随机数 (65, 90)
  25. .计次循环尾 ()
  26. 随机文本 = 到文本 (随机数据)
  27. .计次循环首 (取数组成员数 (用作分割的文本数组), 计数)
  28.     待分割文本副本 = 子文本替换 (待分割文本副本, 用作分割的文本数组 [计数], 随机文本, , , 真)
  29. .计次循环尾 ()
  30. .如果 (是否为空 (要返回的子文本数目))
  31.     返回值 = 分割文本 (待分割文本副本, 随机文本, )
  32. .否则
  33.     返回值 = 分割文本 (待分割文本副本, 随机文本, 要返回的子文本数目)
  34. .如果结束


复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则