每日签到免扫码快速登录设为首页收藏本站帮助中心
查看: 16|回复: 0
收起左侧

易语言实现两个文本型字符串(或字节集数据)的尾部(右边)近似等于包容比较(返回逻辑型)

[复制链接]

签到天数: 7 天

[LV.3]偶尔看看II

发表于 2020-1-13 17:15 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (近似等于_尾 (“12345”, “345”))
  9. 输出调试文本 (近似等于_尾 (“12345”, “45”))
  10. 输出调试文本 (近似等于_尾 (“12345”, “@”))
  11. 输出调试文本 (近似等于_尾 (“1.txt”, “.txt”))
  12. 输出调试文本 (近似等于_尾 (“1.txt”, “h”))
  13. 输出调试文本 (近似等于_尾 (“Hello World! 中文测试”, “中文测试”))
  14. 输出调试文本 (近似等于_尾 (“Hello”, “中文测试”))

  15. 输出调试文本 (近似等于_尾_字节集 ({ 1, 2, 3, 4, 5 }, { 3, 4, 5 }))
  16. 输出调试文本 (近似等于_尾_字节集 ({ 1, 2, 3, 4, 5, 6, 7 }, { 4, 5, 6, 7 }))
  17. 输出调试文本 (近似等于_尾_字节集 ({ 1, 2, 3, 4, 5 }, { 1 }))




  18. .子程序 近似等于_尾, 逻辑型, 公开, 当比较文本在被比较文本的尾部被包容时返回真,否则返回假
  19. .参数 被比较文本, 文本型
  20. .参数 比较文本, 文本型

  21. .如果真 (比较文本 = “” 或 被比较文本 = “”)
  22.     返回 (假)
  23. .如果真结束
  24. 返回 (取文本右边 (被比较文本, 取文本长度 (比较文本)) = 比较文本)

  25. .子程序 近似等于_尾_字节集, 逻辑型, 公开, 当比较字节集在被比较字节集的尾部被包容时返回真,否则返回假
  26. .参数 被比较字节集, 字节集
  27. .参数 比较字节集, 字节集

  28. .如果真 (比较字节集 = {  } 或 被比较字节集 = {  })
  29.     返回 (假)
  30. .如果真结束
  31. 返回 (取字节集右边 (被比较字节集, 取字节集长度 (比较字节集)) = 比较字节集)

复制代码
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则