设为首页收藏本站帮助中心
查看: 2094|回复: 0
收起左侧

易语言实现检测、搜索、判断日期时间型数组中是否存在指定星期的成员 (返回逻辑型)

[复制链接]
发表于 2020-2-24 23:04:22 | 显示全部楼层 |阅读模式
111.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (日期时间型数组_是否存在指定星期 ({ [2020年1月1日], [2020年2月24日] }, 2))
  9. 输出调试文本 (日期时间型数组_是否存在指定星期 ({ [2020年1月1日], [2020年2月24日] }, 1))



  10. .子程序 日期时间型数组_是否存在指定星期, 逻辑型, 公开, 存在指定星期的日期时间返回真,否则返回假
  11. .参数 数组, 日期时间型, 数组
  12. .参数 星期, 字节型, , 星期日为 1,星期一为 2,以此类推。
  13. .局部变量 计数, 整数型

  14. .如果真 (星期 < 1 或 星期 > 7)
  15.     返回 (假)
  16. .如果真结束
  17. .计次循环首 (取数组成员数 (数组), 计数)
  18.     .如果真 (取星期几 (数组 [计数]) = 星期)
  19.         返回 (真)
  20.     .如果真结束

  21. .计次循环尾 ()
  22. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则