设为首页收藏本站帮助中心
查看: 2131|回复: 0
收起左侧

易语言获取字节型/短整数型/整数型/长整数型数组中是否存在指定范围的值 (返回逻辑型)

[复制链接]
发表于 2020-2-27 20:00:22 | 显示全部楼层 |阅读模式
111.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  8. 输出调试文本 (字节型数组_是否存在范围数字 ({ 46, 47, 58, 50 }, 48, 57))
  9. 输出调试文本 (短整数型数组_是否存在范围数字 ({ -11, 11, -2 }, -5, 10))
  10. 输出调试文本 (整数型数组_是否存在范围数字 ({ 1, 2, 3, 4, 5, 6, 7, 15 }, 12, 15))
  11. 输出调试文本 (长整数型数组_是否存在范围数字 ({ -11, 11 }, -10, 10))



  12. .子程序 字节型数组_是否存在范围数字, 逻辑型, 公开
  13. .参数 数组, 字节型, 数组
  14. .参数 最小值, 字节型
  15. .参数 最大值, 字节型
  16. .局部变量 计数, 整数型

  17. .计次循环首 (取数组成员数 (数组), 计数)
  18.     .如果真 (数组 [计数] ≥ 最小值 且 数组 [计数] ≤ 最大值)
  19.         返回 (真)
  20.     .如果真结束

  21. .计次循环尾 ()
  22. 返回 (假)

  23. .子程序 短整数型数组_是否存在范围数字, 逻辑型, 公开
  24. .参数 数组, 短整数型, 数组
  25. .参数 最小值, 短整数型
  26. .参数 最大值, 短整数型
  27. .局部变量 计数, 整数型

  28. .计次循环首 (取数组成员数 (数组), 计数)
  29.     .如果真 (数组 [计数] ≥ 最小值 且 数组 [计数] ≤ 最大值)
  30.         返回 (真)
  31.     .如果真结束

  32. .计次循环尾 ()
  33. 返回 (假)

  34. .子程序 整数型数组_是否存在范围数字, 逻辑型, 公开
  35. .参数 数组, 整数型, 数组
  36. .参数 最小值, 整数型
  37. .参数 最大值, 整数型
  38. .局部变量 计数, 整数型

  39. .计次循环首 (取数组成员数 (数组), 计数)
  40.     .如果真 (数组 [计数] ≥ 最小值 且 数组 [计数] ≤ 最大值)
  41.         返回 (真)
  42.     .如果真结束

  43. .计次循环尾 ()
  44. 返回 (假)

  45. .子程序 长整数型数组_是否存在范围数字, 逻辑型, 公开
  46. .参数 数组, 长整数型, 数组
  47. .参数 最小值, 长整数型
  48. .参数 最大值, 长整数型
  49. .局部变量 计数, 整数型

  50. .计次循环首 (取数组成员数 (数组), 计数)
  51.     .如果真 (数组 [计数] ≥ 最小值 且 数组 [计数] ≤ 最大值)
  52.         返回 (真)
  53.     .如果真结束

  54. .计次循环尾 ()
  55. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则