设为首页收藏本站帮助中心
查看: 1715|回复: 0
收起左侧

易语言实现判断系统Temp/TMP临时目录是否可正常创建写入删除临时文件 (返回逻辑型)

[复制链接]
发表于 2020-3-2 19:53:28 | 显示全部楼层 |阅读模式
1.png



  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型


  4. _临时子程序 ()
  5. 返回 (0)

  6. .子程序 _临时子程序


  7. .如果真 (临时目录是否可写 () = 假)
  8.     信息框 (“临时目录不能写入数据,请尝试重启系统!”, 16, , )
  9. .如果真结束


  10. .子程序 临时目录是否可写, 逻辑型, 公开
  11. .参数 目录名, 文本型, 可空, 可以被省略。如果省略本参数,默认将使用系统的标准临时目录。
  12. .局部变量 临时文件名, 文本型

  13. .如果 (是否为空 (目录名))
  14.     临时文件名 = 取临时文件名 ()
  15. .否则
  16.     临时文件名 = 取临时文件名 (目录名)
  17. .如果结束
  18. .判断开始 (文件是否存在 (临时文件名))
  19.     返回 (假)
  20. .判断 (写到文件 (临时文件名, 到字节集 (临时文件名)) = 假)
  21.     返回 (假)
  22. .判断 (文件是否存在 (临时文件名) = 假)
  23.     返回 (假)
  24. .判断 (置文件属性 (临时文件名, 39) = 假)
  25.     返回 (假)
  26. .判断 (置文件属性 (临时文件名, 0) = 假)
  27.     返回 (假)
  28. .判断 (删除文件 (临时文件名) = 假)
  29.     返回 (假)
  30. .判断 (文件是否存在 (临时文件名))
  31.     返回 (假)
  32. .默认

  33. .判断结束
  34. 返回 (真)


复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则