设为首页收藏本站帮助中心
查看: 1894|回复: 0
收起左侧

易语言调用mshta.exe的JavaScript实现弹出信息框 (不等待用户点击按钮 , 返回逻辑型)

[复制链接]
发表于 2020-3-4 10:32:06 | 显示全部楼层 |阅读模式
1.png


  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序


  7. 信息框_JS (“Hello World! 中文测试”)



  8. .子程序 信息框_JS, 逻辑型, 公开, 调用mshta的JavaScript弹出信息框(不等待用户点击按钮),成功返回真失败返回假
  9. .参数 提示信息, 文本型

  10. 提示信息 = 子文本替换 (提示信息, “\”, “\\”, , , 真)
  11. 提示信息 = 子文本替换 (提示信息, #引号, “\” + #引号, , , 真)
  12. 返回 (运行 (“mshta javascript:alert(” + #引号 + 提示信息 + #引号 + “);window.close();”, 假, #隐藏窗口))



复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则