设为首页收藏本站帮助中心
查看: 26|回复: 0
收起左侧

易语言使用 打开加密文件() 实现RC4算法加解密字节集数据(加密后长度不变,返回字节集)

[复制链接]
发表于 2020-3-23 18:09:22 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 加密后, 字节集
  9. .局部变量 解密后, 字节集
  10. .局部变量 加密前, 字节集

  11. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。


  12. 加密前 = 到字节集 (“Hello World!中文测试”)

  13. 加密后 = 字节集_加解密 (加密前, “123456”)
  14. 解密后 = 字节集_加解密 (加密后, “123456”)
  15. 调试输出 (加密前)
  16. 调试输出 (加密后)
  17. 调试输出 (解密后, 到文本 (解密后))
  18. 检查 (加密前 = 解密后)


  19. .子程序 字节集_加解密, 字节集, 公开, 使用 打开加密文件() 加解密字节集数据,成功返回字节集,失败返回空字节集
  20. .参数 字节集, 字节集
  21. .参数 数据密码, 文本型, , 密钥必须正确,否则将返回错误的数据
  22. .局部变量 临时文件名, 文本型
  23. .局部变量 文件号, 整数型
  24. .局部变量 返回值, 字节集

  25. 临时文件名 = 取临时文件名 ()
  26. 文件号 = 打开加密文件 (临时文件名, #重写, #禁止读写, 数据密码, )
  27. .判断开始 (文件号 = 0)
  28.     返回 ({  })
  29. .判断 (写出字节集 (文件号, 字节集) = 假)
  30.     返回 ({  })
  31. .默认

  32. .判断结束
  33. 关闭文件 (文件号)
  34. 返回值 = 读入文件 (临时文件名)
  35. 删除文件 (临时文件名)
  36. 返回 (返回值)

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则