设为首页收藏本站帮助中心
查看: 33|回复: 0
收起左侧

易语言实现超级结束,解决核心库的 结束() 命令在多线程情况下无法正常结束 (无返回值)

[复制链接]
发表于 2020-3-25 18:34:01 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 超级结束 ()


  8. .子程序 超级结束, , 公开, 当在多线程或其他情况下 结束() 无法结束当前易程序的运行时,可使用本方法结束 (结束3次失败将强制崩溃)
  9. .局部变量 结束次数, 字节型, 静态

  10. 处理事件 ()
  11. 结束次数 = 结束次数 + 1
  12. .如果真 (结束次数 ≥ 3)
  13.     输出调试文本 (“超级结束错误次数过多,开始强制崩溃...”)
  14.     置入代码 ({ 232, 251, 255, 255, 255 })  ' call $
  15. .如果真结束
  16. 结束 ()

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则