设为首页收藏本站帮助中心
查看: 2421|回复: 0
收起左侧

易语言调用php.exe控制台程序实现运行一段PHP代码(成功返回真,失败返回假,返回逻辑型)

[复制链接]
发表于 2020-3-28 21:27:01 | 显示全部楼层 |阅读模式
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1
  4. .程序集变量 PHP路径, 文本型

  5. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  6. PHP路径 = “D:\Server\php-7.3.1-Win32-VC15-x64\php.exe”
  7. .如果真 (文件是否存在 (PHP路径) = 假)
  8.     信息框 (“文件 ” + PHP路径 + “ 不存在! 请确认PHP是否正确安装。”, 16, , )
  9.     返回 (0)
  10. .如果真结束
  11. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  12. 返回 (0)  ' 可以根据您的需要返回任意数值

  13. .子程序 _临时子程序
  14. .局部变量 回显, 文本型
  15. .局部变量 错误回显, 文本型
  16. .局部变量 返回值, 整数型

  17. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  18. 检查 (运行PHP代码 (“echo sha1('Hello World!');”, 回显, 错误回显, 返回值))
  19. 调试输出 (回显)
  20. 调试输出 (错误回显)
  21. 调试输出 (返回值)


  22. .子程序 运行PHP代码, 逻辑型, 公开, 调用 php.exe 运行PHP代码,成功返回真,失败返回假
  23. .参数 PHP代码, 文本型, , 代码无需添加 <?php ... ?>
  24. .参数 回显存放变量, 文本型, 参考 可空, echo等函数回显的内容会存放在该变量
  25. .参数 错误回显存放变量, 文本型, 参考 可空, PHP执行错误或警告信息会存放在该变量
  26. .参数 返回值变量, 整数型, 参考 可空, php.exe 运行结束后返回的整数会存放在该变量

  27. PHP代码 = 子文本替换 (PHP代码, “\”, “\\”, , , 真)
  28. PHP代码 = 子文本替换 (PHP代码, #引号, “\” + #引号, , , 真)
  29. 返回 (运行控制台程序 (PHP路径 + “ -r ” + #引号 + PHP代码 + #引号, 回显存放变量, 错误回显存放变量, 返回值变量))
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则