设为首页收藏本站帮助中心
查看: 650|回复: 0
收起左侧

易语言MASM置入代码将字符串所有非数字字符全部替换为0 (不处理半角数字0~9,无返回值)

[复制链接]
发表于 2020-3-31 23:25:00 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png


  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 字符串, 文本型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 字符串 = “1234567890Hello World! 1234567890中文测试9876543210”
  10. 文本型_非数字替换为0 (字符串)
  11. 信息框 (字符串, 0, , )



  12. .子程序 文本型_非数字替换为0, , 公开, 半角数字0~9不做处理,其余数字一律替换为0
  13. .参数 字符串变量, 文本型, 参考

  14. 置入代码 ({ 96, 139, 69, 8, 11, 192, 117, 2, 235, 35, 139, 0, 11, 192, 117, 2, 235, 27, 138, 24, 10, 219, 117, 4, 235, 19, 235, 14, 128, 251, 48, 114, 5, 128, 251, 57, 118, 4, 179, 48, 136, 24, 64, 235, 229, 97 })
  15. ' pushad
  16. ' mov eax,[ebp+8]
  17. ' .if eax == 0
  18. ' jmp ASM_END
  19. ' .endif
  20. ' mov eax,[eax]
  21. ' .if eax == 0
  22. ' jmp ASM_END
  23. ' .endif
  24. ' .while 1
  25. ' mov bl,[eax]
  26. ' .if bl ==0
  27. ' .break
  28. ' .elseif bl < 48 || bl > 57
  29. ' mov bl,48
  30. ' mov [eax],bl
  31. ' .endif
  32. ' inc eax
  33. ' .endw
  34. ' ASM_END:
  35. ' popad

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则